OTA after changeover from Daylight Savings Time to Standard Time sets date back to Jan 6, 1970

RESOLVED DUPLICATE of bug 1061797

Status

Firefox OS
Gaia::System
RESOLVED DUPLICATE of bug 1061797
4 years ago
4 years ago

People

(Reporter: pragmatic, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Created attachment 8516417 [details]
1970-01-06-14-37-33.png

Steps to reproduce
1. Flash a Flame device with the v188 base image and then full flash b2g v2.1 of a date earlier than the day on which Daylight Savings Time (DST) ends (i.e. Nov 2, 2014)
For example: https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/nightly/mozilla-b2g34_v2_1-flame-kk/2014/10/2014-10-31-16-12-01/
2. Go through the First Time User (FTU) experience and set the date and time accurately to the current date and time.
3. Connect to WiFi and wait for a few minutes till you are prompted for a System Update. (Alternatively, use the Settings menu to check for updates right away.)
4. Download the Over The Air (OTA) update and apply it.

Expected Results
The phone reboots after the update and retains the current date and time.

Actual Results
The phone reboots after the update and does not retain the current date and time. The date gets set back to Jan 6, 1970 and the time is shown as 30 minutes later than what it actually is.
(See screenshot attached. It was taken at 2014-11-03-14-07-33 but the system time dictates that the screenshot is named 1970-01-06-14-37-33.png.)
Created attachment 8516423 [details]
1093430-adb-logcat.txt

adb logcat attached.

Comment 2

4 years ago
[Blocking Requested - why for this release]:
We can't be updating users and resetting the system to Jan 6, 1970.   ni? dhylands if he has an idea.

Qawanted to see if this reproduces on 2.0
blocking-b2g: --- → 2.1?
Flags: needinfo?(dhylands)
Keywords: qawanted
I think this is all related to the weird way that qualcomm uses the modem to update the RTC.

I haven't really been involved in that particular bug, other than reporting.

I seem to recall that gsvelto did a bunch of work/investigation, so I'll ni? him.
Flags: needinfo?(dhylands) → needinfo?(gsvelto)
Yep, I've sunk an inordinate amount of time of this but there's no solution in sight without help from the vendor. Dup'ing this against the most relevant bug on the topic.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(gsvelto)
Resolution: --- → DUPLICATE
Duplicate of bug: 1061797
blocking-b2g: 2.1? → ---
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.