[email/IMAP] IMAP prober fails on servers that do not provide UIDNEXT when entering a folder. (For example, coremail servers like 163.com).

VERIFIED FIXED

Status

Firefox OS
Gaia::E-Mail
--
major
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: yong.ren, Assigned: asuth)

Tracking

unspecified

Firefox Tracking Flags

(b2g-v2.1 verified, b2g-v2.2 verified)

Details

(Whiteboard: [sprd 367098] )

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20141102030204

Steps to reproduce:

1. open email 
2. input name and 163 email address, click next
3. Enter the password for 163 email address

[ firefox os version is 2.1] 


Actual results:

failed to setup 163 email account


Expected results:

163 email account can be setup succesfully
(Reporter)

Comment 1

4 years ago
Hi Andrew and jrburke:

  when the problem occurs, the email log are as follows:

11-03 23:40:07.720 E/GeckoConsole(  858): Content JS LOG at app://email.gaiamobile.org/js/html_cache_restore.js:11 in e: Skipping cookie cache, out of date. Expected b6dc857cd3cee2f2c7791e376d6d802c58cd386a but found undefined
11-03 23:40:09.480 I/Gecko   (  858): WLOG: Email knows that it is: online and previously was: online
11-03 23:40:09.490 I/Gecko   (  858): WLOG: deferring getConfig call until ready
11-03 23:40:09.520 I/GeckoDump(  858): LOG: MailDB in onupgradeneeded
11-03 23:40:09.540 I/Gecko   (  858): WLOG: main thread reports DB ready
11-03 23:40:09.540 I/Gecko   (  858): WLOG: issuing getConfig call to main thread
11-03 23:40:09.560 I/Gecko   (  858): WLOG: cronsync: ensureSync called
11-03 23:40:09.590 I/Gecko   (  858): WLOG: Mail universe/bridge created and notified!
11-03 23:40:09.600 I/GeckoDump(  858): LOG: cronsync-main: ensureSync called
11-03 23:40:09.620 I/GeckoDump(  858): LOG: cronsync-main: success!
11-03 23:40:09.620 I/GeckoDump(  858): LOG: cronsync-main: ensureSync completed
11-03 23:40:09.630 I/Gecko   (  858): WLOG: cronsync: received an syncEnsured via a message handler
11-03 23:40:09.720 I/GeckoDump(  858): LOG: pushCard for type: setup_account_info
11-03 23:40:10.400 I/GeckoDump(  858): LOG: htmlCache.save: 2289 in 2 segments
11-03 23:40:46.390 I/GeckoDump(  858): LOG: pushCard for type: setup_progress
11-03 23:40:46.400 I/Gecko   (  858): WLOG: [slog] autoconfig:begin {"domain":"163.com"}
11-03 23:40:46.410 I/Gecko   (  858): WLOG: [slog] autoconfig.xhr:start {"method":"GET","url":"/autoconfig/163.com"}
11-03 23:40:46.710 I/Gecko   (  858): WLOG: [slog] autoconfig.xhr:end {"method":"GET","url":"/autoconfig/163.com","status":200}
11-03 23:40:46.810 I/Gecko   (  858): WLOG: [slog] autoconfig:end {"domain":"163.com","result":"need-password","source":"local","configInfo":{"type":"imap+smtp","incoming":{"hostname":"imap.163.com","port":"993","socketType":"SSL","username":"betatest1234@163.com","authentication":"password-cleartext"},"outgoing":{"hostname":"smtp.163.com","port":"465","socketType":"SSL","username":"betatest1234@163.com","authentication":"password-cleartext"},"oauth2Settings":null}}
11-03 23:40:47.230 I/GeckoDump(  858): LOG: pushCard for type: setup_account_password
11-03 23:41:19.140 I/GeckoDump(  858): LOG: pushCard for type: setup_progress
11-03 23:41:19.140 I/Gecko   (  858): WLOG: [slog] autoconfig:begin {"domain":"163.com"}
11-03 23:41:19.140 I/Gecko   (  858): WLOG: [slog] autoconfig.xhr:start {"method":"GET","url":"/autoconfig/163.com"}
11-03 23:41:19.300 I/Gecko   (  858): WLOG: [slog] autoconfig.xhr:end {"method":"GET","url":"/autoconfig/163.com","status":200}
11-03 23:41:19.320 I/Gecko   (  858): WLOG: [slog] autoconfig:end {"domain":"163.com","result":"need-password","source":"local","configInfo":{"type":"imap+smtp","incoming":{"hostname":"imap.163.com","port":"993","socketType":"SSL","username":"betatest1234@163.com","authentication":"password-cleartext"},"outgoing":{"hostname":"smtp.163.com","port":"465","socketType":"SSL","username":"betatest1234@163.com","authentication":"password-cleartext"},"oauth2Settings":null}}
11-03 23:41:20.980 I/Gecko   (  858): WLOG: [slog] oauth:credentials-ok
11-03 23:41:20.980 I/Gecko   (  858): WLOG: [slog] oauth:credentials-ok
11-03 23:41:21.000 I/Gecko   (  858): WLOG: [slog] smtp:connect {"usingOauth2":false,"connInfo":{"emailAddress":"betatest1234@163.com","hostname":"smtp.163.com","port":"465","crypto":"ssl"}}
11-03 23:41:23.520 I/Gecko   (  858): WLOG: [slog] probe:smtp:checking-address-validity
11-03 23:41:26.110 I/Gecko   (  858): WLOG: [slog] imap:protocol-error {"humanReadable":"Parse command error"}


please help to check this problem, 

if you have any problem, need info for me, i will reply quickly.

thanks a lot.
status-b2g-v2.1: --- → affected
Flags: needinfo?(jrburke)
Flags: needinfo?(bugmail)
Whiteboard: [sprd 367098]
(Reporter)

Updated

4 years ago
Severity: normal → major
Looks like we will need to debug the protocol flow when talking to the 163.com server, not all of it is coming across in the logs. 

Could you provide us with a 163.com account that we could use for general email dev testing? Ideally it would be one that demonstrates this error and an account we could use on an ongoing testing basis if other issues come up with that serer.

You can send the email and password privately to jburke@mozilla.com and I can distribute it to the other dev owners for email.
Flags: needinfo?(yong.ren)
Flags: needinfo?(jrburke)
Flags: needinfo?(bugmail)
(Reporter)

Comment 3

4 years ago
Hi James:

  I have send our 163.com test account to your email. 

  thanks for your help to investigate this problem, if you have any problem, please need info for me, 
  i will reply quickly.
Flags: needinfo?(yong.ren)
(Assignee)

Comment 4

4 years ago
The initial problem seems to be the failure of the IMAP prober due to the server not providing a UIDNEXT value in arguable violation of RFC 3501.  This is also what we're seeing on bug 1082740.  I'm going to treat this bug as the canonical one because 163.com is an important server for rhetorical purposes and dupe that one to this.
status-b2g-v2.2: --- → affected
Summary: [E-Mail] failed to setup 163.com email account in firefox os 2.1 → [email/IMAP] IMAP prober fails on servers that do not provide UIDNEXT when entering a folder. (For example, coremail servers like 163.com).
(Assignee)

Updated

4 years ago
Depends on: 1097421
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1082740
(Assignee)

Comment 6

4 years ago
I have a fix for this as part of the bug 1097421 omnibus that allows me to use 163.com on v2.2.
Assignee: nobody → bugmail
Status: NEW → ASSIGNED
(Assignee)

Comment 7

4 years ago
Fixed as part of bug 1097421's omnibus patch. Many servers were experiencing more than one bug, and we had experienced some upstream drift, and especially for uplift tracking, it made sense to land these together.  See the gaia-email-libs-and-more pull request's specific commits for the specific fixes and tests.  I am planning to request v2.1 uplift shortly after performing v2.1 testing.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
status-b2g-v2.2: affected → fixed
Resolution: --- → FIXED
(Reporter)

Comment 8

4 years ago
Hi Andrew:

   please resolve this bug  on b2g-v2.1, thanks  a lot!
Flags: needinfo?(bugmail)
(Assignee)

Comment 9

3 years ago
Batching marking v2.1 fixed since the uplift of bug 1097421 occurred on Dec 9th, thereby fixing all dependent bugs of bug 1097421 on v2.1.  Uplift commit comment is https://bugzilla.mozilla.org/show_bug.cgi?id=1097421#c6
status-b2g-v2.1: affected → fixed
(Assignee)

Updated

3 years ago
Flags: needinfo?(bugmail)

Comment 10

3 years ago
Created attachment 8543577 [details]
Verify_image.png

This issue has been verified successfully on Flame 2.1,2.2
See attachment: Verify_image.png
Reproducing rate: 0/5

Flame 2.1:
Gaia-Rev        73be51f998031f06db0cd660c0e388fa621c9f4c
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/05dd053f1d90
Build-ID        20150103001211
Version         34.0
--------------------------
Flame 2.2:
Gaia-Rev        698e6e8a098cc060b26cd6f25171633c4c7e739d
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/57e4e9c33bef
Build-ID        20150103010205
Version         37.0a1

Updated

3 years ago
status-b2g-v2.1: fixed → verified
status-b2g-v2.2: fixed → verified

Updated

3 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.