Persian language Yeh character rendering problem in locamotion

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: amir_farsi, Unassigned)

Tracking

Details

(URL)

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

4 years ago
Created attachment 8516534 [details]
persianAtLocamotion.jpg

User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/38.0.2125.111 Safari/537.36

Steps to reproduce:

Hello to all.
In locamotion(mozilla.locamotion.org), when i want translate mozilla products to persian language, when i enter the words like firefox in persian language as فایرفاکس the yeh(ی) character shows separated. it shows فایرفاکس as فای‌رفاکس which is invalid.


Actual results:

when i enter the words like firefox in persian language as فایرفاکس the yeh(ی) character shows separated. it shows فایرفاکس as فای‌رفاکس which is invalid. This problems shows in picture.


Expected results:

the yeh character in persian language when is between other characters, must not separted.
(Reporter)

Updated

4 years ago
(Reporter)

Comment 1

4 years ago
I found same problem in verbatim. I think this is poottle problem. Also this problem wasn't in vebatim and locamotion before now. I think this problem is for latest version of poottle and wasn't in older versions of poottle.
Thank you for pointing this out Amir. I'm flagging Dwayne to take a look into this issue. Hopefully if this wasn't a problem before, it'll be a quick fix now.

On another note, I should mention that Mozilla branding guidelines require that product and brand names like Firefox should remain untranslated and in Latin script.
Flags: needinfo?(dwayne)
(Reporter)

Comment 3

4 years ago
Thanks for your mention Jeff. I will be Fix the Translation of Product and Brand names  like Firefox to untranslated. But Jeff, I translated this things, because most of local users which wants to use localized contents, are using translated Brand names of Mozilla. In most of local sites(Persian sites) Firefox is not used and only فایرفاکس is used as translated Product name. Also they search translated names in search engines such as Google.

Comment 4

4 years ago
At first glance it is almost certainly not a Pootle problem.  Pootle simply stores the text as supplied.  Rendering is handled by the platform and the browser.  Since both platforms haven't been changed for some time and since this seems to be a new problem, most likely it is any changes in the rendering stack.

Amir can you try this on various browser including older ones and on other platforms, to validate if this is related to the version or platform.
Flags: needinfo?(dwayne)
(Reporter)

Comment 5

4 years ago
Hello Dwayne. Your comment is correct and is not correct!
I tested pootle(locomotion and verbatim) in Internet Explorer 11 on Windows 8.1 Also, and I added the screenshot in this bug report. It shows the Yeh character invalid such as Chrome. But these browsers(IE and Chrome) shows this character correctly in other sites as well as sumo(support.mozilla.org) and I added the screenshot of it to this bug report.

But, I tested pootle(locomotion and verbatim) in Internet Explorer 11 Compatibility mode on windows 8.1 and it shows Yeh character correctly! I added the screenshot of it also.

As result, pootle isn't compatible with modern browser such as Chrome(latest Version)and IE 11, but pootle is compatible with old and legacy browsers such as IE 11 Compatibility mode. This things shows maybe the CSS of pootle must be upgraded for having compatibility with new web browsers.
Thanks.
(Reporter)

Comment 6

4 years ago
Created attachment 8585465 [details]
pootle have not problem with persian yeh character in IE11 compatibility mode
(Reporter)

Comment 7

4 years ago
Created attachment 8585468 [details]
Pootle have problem with yeh character(Persian language) in IE11
(Reporter)

Updated

4 years ago
Attachment #8585465 - Attachment description: pootle have problem with persian yeh character in IE11 → pootle have not problem with persian yeh character in IE11 compatibility mode
(Reporter)

Comment 8

4 years ago
Created attachment 8585470 [details]
pootle shwos persian yeh character correcly in IE11 Compatibility mode
Attachment #8585465 - Attachment is obsolete: true
(Reporter)

Updated

4 years ago
Attachment #8585470 - Attachment description: pootle haven't shwos persian yeh character correcly in IE11 Compatibility mode → pootle shwos persian yeh character correcly in IE11 Compatibility mode
(Reporter)

Comment 9

4 years ago
Created attachment 8585471 [details]
Yeh persian character Havn't Problem In IE 11
(Reporter)

Updated

4 years ago
Attachment #8585471 - Attachment description: Yeh persian character Havnt Problem In IE 11 → Yeh persian character Havn't Problem In IE 11
Pinging Dwayne to see if he's seen Amir's last comment.
Flags: needinfo?(dwayne)
(Reporter)

Comment 11

3 years ago
I want to inform Now(2015/11/20), pootle is showing Persian Yeh character correctly.
I tested it on IE 11(Both normal and compatibility mode), Firefox 44 dev edition and Google Chrome 46 on Windows 10 64 bit.But i don't know is it only on windows 10 correct, or on all versions of windows?

Arash and Sara, if you have earlier versions of Windows or and Linux, please check it. If it's correct, i will change of this bug to resolved.
Flags: needinfo?(s.mansoury)
Flags: needinfo?(arash.moosavi)

Comment 12

3 years ago
Thanks Amir.  Lets see on the other versions.  I'd like to hear on older versions.  But hopefully we can just close this.
Flags: needinfo?(dwayne)
(Reporter)

Updated

3 years ago
Flags: needinfo?(arash.moosavi) → needinfo?(mousavi.arash)
There are multiple reasons that this problem might happen:

1) The text is written with an old and not standard Persian keyboard layout that is using a wrong Unicode value for ی.
2) The font that has been used for rendering is not standard and the position of ی is wrong in it.

These problems both been known issues with previous versions of Windows (very old ones). Even if this is true, I believe there's no way to fix it on Pootle while rendering fonts is not a responsibility of a web app.
Flags: needinfo?(mousavi.arash)
(Reporter)

Updated

3 years ago
Flags: needinfo?(s.mansoury)

Comment 14

3 years ago
Amir I checked it on windows 7 and it was ok for me
(Reporter)

Comment 15

3 years ago
Ok.
Thanks Sara for your checking. It's look like this bug is fixed in latest version of Pootle.
Thanks Jeff, Dwayne, and Arash for your great comments.
I will change this Bug status to WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.