Closed Bug 1093546 Opened 6 years ago Closed 5 years ago

Passwordmanagercommon stalls (hi cpu) then crashes firefox

Categories

(Toolkit :: Password Manager, defect)

32 Branch
x86_64
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1239657

People

(Reporter: f0rhum, Unassigned)

Details

(Keywords: crash, Whiteboard: [passwords:management])

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:32.0) Gecko/20100101 Firefox/32.0
Build ID: 20140924083558

Steps to reproduce:

Wanted to purge my passwords huge store for Sync purpose/tests. I selected "Delete all".
logins.json ~ 670kB
key3.db ~ 16kB


Actual results:

A popup went stating the script ..../Passwordmanagercommon.js (with 203 or 97 info) seems hanged and asking "Continue/Cancel/Debug" with option to no prompt anymore, which I checked and clicked Continue.
Popup stalls, hi cpu, later, FF hanged.
On restart I send the crash report.


Expected results:

All password would be deleted.
OS: Linux → Windows XP
Component: Untriaged → Preferences
In Linux, same behaviour, but in the end all passwords were deleted. Although I had the passwords management window grayed in the end, and I had to click somewhere else then come back and it was not grayed any more and I could close it in the normal way.
Can you include the crash report ID? (about:crashes should be able to tell you)
Flags: needinfo?(f0rhum)
Keywords: crash
Thanks for the link.
Trying again, see also Hi memory usage (1GB, growing) and Hi swap (1,6GB) stable.
Logins.json is now 612kB stable, but time stamp last change is today11h15 when key3.db one is today10h50...
I wait a while to see if crash again. If not I'll kill it...
I'm not prompted any more by the script (I think some no-prompt-again flag was stored before the crash, but I did find something searching in about:config with password or script...)
...FF CPU usage went down normal, FF memory usage went down also but is growing again, FF swap still stable ~1.6GB, Passwords Storing window doesn't respond even when "Swith(ed) to" with Task Manager.
Need to kill:
Previous crash ID:  08f1ccf5-de91-4f59-96ec-ce74e2141104 (the one you asked)
This one: none (clicked Close/AltF4 in task bar then End task in "Application hanged" popup)
PS: for info, on restart key3.db and logins.json still out of same timestamps. But I can delete passwords one by one or twenty by twenty
Flags: needinfo?(f0rhum)
Yeah, the previous crash was an OOM:

https://crash-stats.mozilla.com/report/index/08f1ccf5-de91-4f59-96ec-ce74e2141104

I'm... not sure why this is taking any significant memory at all. Matt, do you know why we can't just nuke the login databases if people use "remove all"?
Flags: needinfo?(MattN+bmo)
Maybe the bug is when the window is refreshed before the whole selected deletion is done. I see again the prompt for the script hanged when I select ~20 pwd for deletion.
I see also sometimes the passordManager.js:173 and tree.xml:77 (~ 100 passwords selected for deletion)
@Gijs, this way would leave the ~bug~ as is when say one delete all but one passwords out of a huge db.
I can add info that when deleting say 10 passwords, it takes very long (just my feeling) time (10~s). Maybe a db perf issue?
(In reply to :Gijs Kruitbosch from comment #4)
> Matt, do you know why we can't just nuke the login databases if people use "remove
> all"?

We have bug 654812 for that. I haven't heard a reason why we shouldn't do that.
Component: Preferences → Password Manager
Flags: needinfo?(MattN+bmo)
Product: Firefox → Toolkit
Whiteboard: [passwords:management]
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1239657
You need to log in before you can comment on or make changes to this bug.