[Flame][v2.1&v2.0][Music]Music time bar operate abnormal when change right-to-left language.

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Music
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: whsu, Assigned: mancas)

Tracking

unspecified
2.1 S9 (21Nov)
ARM
Gonk (Firefox OS)
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(b2g-v2.2 verified)

Details

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 8516612 [details]
WP_20141104_009.mp4

+++ This bug was initially created as a clone of Bug #1091455 +++

This a functional defect and reported by our partner.
Please fix it on v2.1.

* Precondition:
 - Select first language in language list
 - Have some songs in phone.

* Steps to reproduce:
  1) Main menu->Play music->Select one song to play->Tap time bar 
  2) Check the time bar display.

* Actual results
 - Time bar operate abnormal when change right-to-left language.
   (Demo video: WP_20141104_009.mp4)

* Expected results:
 - Time bar should operate normally when change right-to-left language.

* Build Information
  @ Tako
   Gaia-Rev    d056733f8a7a1a152f5458b323f092c47dbffa48
   Gecko-Rev   df0479fb8c18379488013452e903c33bca384b0d
   Build ID    20141024145043
   Version     32.0
  @ Flame
   Gaia-Rev    8b0cf889ae0d48a9eb7ecdcb9b67590de45cc5e5
   Gecko-Rev   https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/388b03efe92d
   Build-ID    20141104001202
   Version     34.0
   
* Reproduce Rate ==
  100%
(Reporter)

Updated

4 years ago
Duplicate of this bug: 1091455
(Reporter)

Comment 2

4 years ago
[Blocking Requested - why for this release]:

This a functional defect and reported by our partner.
Please fix it on v2.1. Thanks.
(Reporter)

Comment 3

4 years ago
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.1?

Updated

4 years ago
Blocks: 1071890

Comment 4

4 years ago
We are looking into all RTL related issues across all apps in 2.2. Adding this to the music-rtl meta bug.

Thanks
Hema
(Assignee)

Updated

4 years ago
Assignee: nobody → b.mcb
(Assignee)

Comment 5

4 years ago
Created attachment 8517370 [details] [review]
Proposed patch

Hey David! Could you review the patch, please?

Let me know if we need to make some changes in the patch.

Thanks!
Attachment #8517370 - Flags: review?(dflanagan)
Not a blocker, but will try to review this soon.
blocking-b2g: 2.1? → ---
Comment on attachment 8517370 [details] [review]
Proposed patch

Hub,

Since you're handling RTL compliance for the Music app, I'm passing this review on to you. If you don't think you're familiar enough with that part of the code to review, feel free to send it back to me.
Attachment #8517370 - Flags: review?(dflanagan) → review?(hub)
Comment on attachment 8517370 [details] [review]
Proposed patch

Looks good to me.
Attachment #8517370 - Flags: review?(hub) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/commit/984555f287b56a6e4d3ab3878640ac92063c9381
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-b2g-v2.2: --- → fixed
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S9 (21Nov)

Updated

4 years ago
Keywords: verifyme

Comment 10

4 years ago
This verified su
status-b2g-v2.2: fixed → verified
Keywords: verifyme

Updated

4 years ago
Status: RESOLVED → VERIFIED

Comment 11

4 years ago
Created attachment 8550055 [details]
VIDEO0250_Compress.MP4

This issue verified successfully on Flame 2.2:
Gaia-Rev        7c5b27cad370db377b18a742d3f3fdb0070e899f
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/ce27f2692382
Build-ID        20150115002505
Version         37.0a2
Reproduce rate  0/5

Updated

3 years ago
Flags: in-moztrap+
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15094/
You need to log in before you can comment on or make changes to this bug.