Texture bleeding in 3d transformed elements.

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: ojl_bugzilla, Unassigned)

Tracking

33 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 8516614 [details]
Bug visible when rendered by Firefox.

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/38.0.2125.111 Safari/537.36

Steps to reproduce:

A div element with a 3d css transformation will show unexpected behaviour at the edges of the div element. This will happen with any kind of content in the div element. I have created a simple demonstration here http://jsbin.com/lacozawosu/1/edit?html,output . In this case, the contents are two absolute positioned div elements with background colours.

You get the same bug without any DOM content in the top div element but instead with a similar checkered background image specified in for it with css.

This bug is present at least in the 33 branch but I believe it also happens several version numbers back as well.


Actual results:

It seems that the edge handling in the 3d renderer is set for the contents to wrap around. This causes the colours of the opposite edge to bleed through to the other edge. I can't think of a case where this would be the expected way to handle this. See the attached image. 


Expected results:

The opposite edge should not bleed through to the other edge as this causes unintended and annoying artifacts. Internet Explorer and Chrome handle this correctly. Also, Firefox with hardware acceleration disabled behaves correctly. See the other attachment for what should happen.
(Reporter)

Comment 1

4 years ago
Created attachment 8516615 [details]
Correct rendering in Chrome
(Reporter)

Comment 2

4 years ago
Created attachment 8516616 [details]
HTML code to produce the bug.

Comment 3

4 years ago
I'm not able to reproduce it in FF36, so I guess it's already fixed.
Could you install Nightly and confirm it's fixed on your side too? https://nightly.mozilla.org/
Flags: needinfo?(ojl_bugzilla)
(Reporter)

Comment 4

4 years ago
Seems to be working correctly in Nightly (36). I guess we can close this then.
Flags: needinfo?(ojl_bugzilla)

Comment 5

4 years ago
Ty. Feel free to reopen it if it's back.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.