If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Change detected for MEMORY_JS_MAIN_RUNTIME_TEMPORARY_PEAK on the 30/10/14

RESOLVED FIXED

Status

()

Core
JavaScript Engine
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: rvitillo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Medusa reported a possible regression for MEMORY_JS_MAIN_RUNTIME_TEMPORARY_PEAK, see http://alerts.telemetry.mozilla.org/index.html#/detectors/1/metrics/736/alerts/?from=2014-10-30&to=2014-10-30

As the histogram has many bins, it's difficult to see what's going on just by looking at medusa's plot but a quick glance of the histogram on the telemetry dashboard (http://telemetry.mozilla.org/#filter=nightly%2F36%2FMEMORY_JS_MAIN_RUNTIME_TEMPORARY_PEAK&aggregates=multiselect-all!Submissions!Mean!5th%20percentile!25th%20percentile!median!75th%20percentile!95th%20percentile&evoOver=Builds&locked=true&sanitize=true&renderhistogram=Graph) shows that the weight of some bins has been shifted to the right, e.g. compare bin [1075K, 1129K] with bin [1129K, 1186K] before and after the 30th. 

The overall median seems to be lower though so it might very well be that when considering all shifts in weight the metric did actually improve. Would be interesting to know what change could have caused this and if the data makes sense.
Questions and observations:

- This appears to be an improvement rather than a regression, right? It's measuring a memory peak, and that has gone down, which is good.

- There's an email alert set up for this measurement (http://dxr.mozilla.org/mozilla-central/source/toolkit/components/telemetry/Histograms.json#393) but I didn't receive any emails about this.

- Can we get a list of the relevant changes that may have affected this?

Thanks.
(Reporter)

Comment 2

3 years ago
(In reply to Nicholas Nethercote [:njn] from comment #1)
> Questions and observations:
> 
> - This appears to be an improvement rather than a regression, right? It's
> measuring a memory peak, and that has gone down, which is good.

Yes.

> - There's an email alert set up for this measurement
> (http://dxr.mozilla.org/mozilla-central/source/toolkit/components/telemetry/
> Histograms.json#393) but I didn't receive any emails about this.

I am looking into it.
 
> - Can we get a list of the relevant changes that may have affected this?

The likely culprit should be in this list: https://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2014-10-29&enddate=2014-10-30. I didn't find anything that is obviously associated with the histogram but since I am not very familiar with the JS Engine I might be missing something. 

I am aware that it's hard to pinpoint culprits when all we have is a range of dates, unfortunately that's the best we can do given that the telemetry data is based on build-ids.
I don't think that hg range is going to be precise, because we don't build Nightlies right at midnight.  There must be some way to map build ids to actual commit ranges.
(Reporter)

Comment 4

3 years ago
(In reply to Andrew McCreight [:mccr8] from comment #3)
> I don't think that hg range is going to be precise, because we don't build
> Nightlies right at midnight.  There must be some way to map build ids to
> actual commit ranges.

Joel, do you have an idea by chance on how to do that?
Flags: needinfo?(jmaher)
(In reply to Andrew McCreight [:mccr8] from comment #3)
> I don't think that hg range is going to be precise, because we don't build
> Nightlies right at midnight.  There must be some way to map build ids to
> actual commit ranges.

I swear I just saw a blog post on planet about somebody who wrote a tool to do this.  I thought it was Benjamin, but I can't find the post on his blog.
looking on tbpl, I see 'N' (nightly) jobs:
https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&searchQuery=nightly

the nightly for:
oct 31st: https://hg.mozilla.org/mozilla-central/pushloghtml?changeset=6bd2071b373f
oct 30th: https://hg.mozilla.org/mozilla-central/pushloghtml?changeset=e0b505a37b1c
oct 29th: https://hg.mozilla.org/mozilla-central/pushloghtml?changeset=80e18ff7c7b2
Flags: needinfo?(jmaher)
(Reporter)

Comment 7

3 years ago
> > - There's an email alert set up for this measurement
> > (http://dxr.mozilla.org/mozilla-central/source/toolkit/components/telemetry/
> > Histograms.json#393) but I didn't receive any emails about this.
> 
> I am looking into it.

There was a bug in the mailing logic and you should correctly receive alerts from now on.
Bug 1090491 and bug 918828 are the only ones in those lists that might be relevant, but I'm not even sure if they are.

Anyway, given that this looks like a slight improvement it's not a problem. Do we need to keep this bug open?
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.