Closed Bug 1093605 Opened 6 years ago Closed 5 years ago

Unable to install marketplace update on B2G Desktop or Mulet, because it fails to properly detect it indeed has network connectivity

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

x86_64
Linux
defect
Not set

Tracking

(b2g-v2.2 fixed)

RESOLVED FIXED
2.1 S9 (21Nov)
Tracking Status
b2g-v2.2 --- fixed

People

(Reporter: gerard-majax, Assigned: mancas)

References

Details

(Keywords: regression)

Attachments

(1 file)

46 bytes, text/x-github-pull-request
gerard-majax
: review+
Details | Review
+++ This bug was initially created as a clone of Bug #1093533 +++

STR:
 0. Boot a mulet with network connectivity on your computer
 1. Wait for the Marketplace update to be notified
 2. Try to install it

Expected:
 Update gets installed, since I do have network connectivity

Actual:
 A dialog tells me I'm not able to install the update.

While the code makes sense for device, we need to also properly handle the case of B2G Desktop and Mulet.
Manuel, once you have fixed bug 1093533, we need to fix the way connectivity is detected and make sure we can install apps update within mulet.
Flags: needinfo?(b.mcb)
Keywords: regression
Assignee: nobody → b.mcb
Summary: Unable to install marketplace update on B2G Desktop or Mulet, system think it is connected on 2G network → Unable to install marketplace update on B2G Desktop or Mulet, because it fails to properly detect it indeed has network connectivity
Attached file Proposed patch
The patch is ready. Please take a look and test it on mulet.

Thanks!
Flags: needinfo?(b.mcb)
Attachment #8518750 - Flags: review?(etienne)
Comment on attachment 8518750 [details] [review]
Proposed patch

Forwarding it to Alexandre, looking good but we should add a testCase too :)
Attachment #8518750 - Flags: review?(etienne) → review?(lissyx+mozillians)
The test cases has been added. Waiting for Bug 1093533 to be landed, in order to update the test result.
That does allows mulet to properly trigger app update download.
Comment on attachment 8518750 [details] [review]
Proposed patch

That looks good now that there is a patch.
Attachment #8518750 - Flags: review?(lissyx+mozillians) → review+
And by patch in comment 6, one must read "test".
The path is complete now.
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/commit/ea6cbd65bb542abb4265fc20764cbffe0f9c466e
Status: NEW → RESOLVED
Closed: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 2.1 S9 (21Nov)
You need to log in before you can comment on or make changes to this bug.