Javascript generated <option> form tags don't work

RESOLVED WORKSFORME

Status

()

Core
Layout: Form Controls
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Jeffrey Schrab, Assigned: rods (gone))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
See the previous URL.  <option> tags for <select> form elements do not appear to
work.  Something like:

<select name="STATE" size="1" onChange="submit();">
     <script>writeUSStateOptions("none");</script>
</select>

...where "writeUSStateOptions" is a Javascript function that dynamically kicks
out a list of <option> tags for the States of the USA taking a parameter of
which State to mark as "checked".
(Reporter)

Comment 1

16 years ago
Ok, it's not QUITE how I described.  Javascript does kick out dynamic <option>
tags correctly and they do show up in drop downs, however, *selection* of an
option in the list does not set a VALUE correctly.

Comment 2

16 years ago
Reporter: Can you try the latest nightly build?

I think this is a duplicate of bug 100511. That bug is fixed in the recent
nightly builds.

Comment 3

16 years ago
Reassigning to HTML Form Controls - 

j_schrab@execpc.com: what build id of Mozilla/N6 are you using?
Please include the build id in any bug report - thanks. 
As  bugzilla@bkor.dhs.org says, this sounds like a bug that has
recently been fixed with the bug 34297 landing - for example,
compare bug 100511, bug 105074.

If the bug still occurs with an up-to-date build, could you please
attach a reduced testcase to this bug via the "Create a new attachment"
link above? That would speed things along considerably.
Assignee: rogerl → rods
Component: Javascript Engine → HTML Form Controls
QA Contact: pschwartau → madhur
(Reporter)

Comment 4

16 years ago
The bug was detected on 2001101117 (I thought Bugzilla would capture that).  I
haven't tried the nightly builds but I will.

Comment 5

16 years ago
this looks like a dup of bug 104904
(Reporter)

Comment 6

16 years ago
I have confirmation that this works properly in the 2001-11-13.03 daily build. 
Sorry about the useless bug submission.
Ok, per reporter's comment, -> WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Updated

16 years ago
QA Contact: madhur → tpreston
You need to log in before you can comment on or make changes to this bug.