[Gaia][System]SHB not hidden when moz-physical-home-button is true

RESOLVED INVALID

Status

Firefox OS
Gaia::System
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: russn, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8516872 [details]
SHB after requesting fullscreen, moz-phsyical-home-button true

When the video app with the bug 1055198 patch (where manifest includes fullscreen_layout) requests fullscreen when the SHB is enabled in gaia settings but moz-physical-home-button is true, the SHB is not hidden; it becomes grey and moves down slightly.

Device: Flame
Gaia: 35e87ac4324f0f3abd93dcc70d61c9f37256a0f5 (with bug 1055198 patch applied)
Gecko: 7e3c85754d32
Firmware: v188
Version: 36.0a1
BuildID: 20141029040208
Hrm, Russ I can't reproduce this. If I add the "fullscreen_layout" key to the manifest in the uitest application [1], calling mozRequestFullscreen does indeed show and hide the SHB as expected. Are you sure this is not a problem with the patch in bug 1055198? Can you verify on the device that the manifest does indeed have the "fullscreen_layout" key?

1.) https://github.com/mozilla-b2g/gaia/blob/62c9bd93341fbfa8bf850c21e73465708f93b503/dev_apps/uitest/manifest.webapp
Flags: needinfo?(rnicoletti)
(Reporter)

Comment 2

3 years ago
Apologies. There is no problem with the patch, it was my mistake. When I installed the video app with the patch, I had not reset the app so that the new manifest would take affect. With that step, this issue is not reproducible.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(rnicoletti)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.