If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Lockscreen] Flickering occurs when unlocking a phone with a passcode

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::System::Lockscreen
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: SMiko, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.1 unaffected, b2g-v2.2 affected)

Details

(Whiteboard: [2.2-Daily-Testing], URL)

(Reporter)

Description

3 years ago
Description: The screen flickers when waking the phone up.

Repro Steps:
1: Update a Flame to 20141104040207
2: Open Settings > Screen Lock > enable a passcode lock
3: Press the Power twice to shut down and wake up the phone. 
4: Slide the slider to the right to unlock the phone.

Actual: Flickering is observed.

Expected:Flicker is not observed.

Device: Flame 2.2
BuildID: 20141104040207
Gaia: 3c50520982560ccba301474d1ac43706138fc851
Gecko: 54d05732f29b
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Notes:
1: This issue ONLY occurs when a passcode is set.

Repro frequency: 5/5

Video clip: http://youtu.be/6p93_lQKCWM
(Reporter)

Comment 1

3 years ago
This issue does NOT occur on Flame 2.1 (319mb/shallow flash)

Actual result: No flickering occurs.

Device: Flame 2.1
BuildID: 20141104001202
Gaia: 8b0cf889ae0d48a9eb7ecdcb9b67590de45cc5e5
Gecko: 388b03efe92d
Gonk: 
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

_________________________________________________________________________________________

This issue DOES repro on Flame 2.2 (319mb/ shallow flash/20141103040202)

Actual result: The screen flickers when waking the phone up.

Device: Flame 2.2
BuildID: 20141103040202
Gaia: bc168c17474dabbcceaa349e9bc7c95654435aec
Gecko: 5999e92e89ff
Gonk: 
Version: 36.0a1 (2.2)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.1: --- → unaffected
status-b2g-v2.2: --- → affected
Flags: needinfo?(pbylenga)
Keywords: regression
Whiteboard: [2.2-Daily-Testing]
The second reproduction in that video looks like a bad graphical corruption.  Going to nominate to block given this will have high visibility, every time you unlock the phone with a passcode.

Calling for a window.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regressionwindow-wanted
QA Contact: rpribble
This issue no longer occurs in today's v2.2. Appears to be fixed as of 11/7/14.

Last build where issue is seen:
Device: Flame 2.2 Master KK (319 MB)
BuildID: 20141106040207 (shallow flash)
Gaia: 068b9711277b06c7d633517f9e1fcb5624bb39b3
Gecko: a074c0112919
Gonk: n/a
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First build where issue no longer seen:
Device: Flame 2.2 Master KK (319 MB)
BuildID: 20141107040206 (shallow flash)
Gaia: 779f05fead3d009f6e7fe713ad0fea16b6f2fb31
Gecko: 64f4392d0bdc
Gonk: n/a
Version: 36.0a1 (2.2 Master)
Firmware: V188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Actual results:
Screen no longer flashes black when unlocked.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: regressionwindow-wanted
Status: NEW → RESOLVED
Last Resolved: 3 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
QA Contact: rpribble
Resolution: --- → WORKSFORME
blocking-b2g: 2.2? → ---
You need to log in before you can comment on or make changes to this bug.