Disable app install for runtimes that don't allow it

RESOLVED FIXED in Firefox 36

Status

RESOLVED FIXED
4 years ago
5 months ago

People

(Reporter: jryans, Assigned: paul)

Tracking

(Blocks: 1 bug)

unspecified
Firefox 36
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Some people during Dev. Edition trials attempted to install an app to:

* Local Runtime
* Chrome Desktop

This does not work because they don't support apps today, but we still let you try, which confusing.
(Reporter)

Comment 1

4 years ago
Paul, maybe you want to look at this?
Flags: needinfo?(paul)
(Reporter)

Comment 2

4 years ago
I was thinking we could disable based on whether the webapps actor exists.
(Reporter)

Updated

4 years ago
See Also: → bug 1077502
(Assignee)

Comment 3

4 years ago
Yes. And we can add a warning/error to details.xhtml to say that the app can not be installed on this runtime.
Flags: needinfo?(paul)
(Reporter)

Updated

4 years ago
Blocks: 1094356
(Assignee)

Comment 4

4 years ago
Created attachment 8519729 [details] [diff] [review]
v1
Assignee: nobody → paul
Status: NEW → ASSIGNED
Attachment #8519729 - Flags: review?(jryans)
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1084281
(Assignee)

Comment 7

4 years ago
I don't have any iOS device at the moment to test this patch.
(Reporter)

Comment 8

4 years ago
Comment on attachment 8519729 [details] [diff] [review]
v1

Review of attachment 8519729 [details] [diff] [review]:
-----------------------------------------------------------------

Works as intended for Chrome and iOS. (P.S. if you have a Mac but no iOS device, you can also connect to the iOS Simulator.)

For the Local Runtime, the play button is still enabled, but then fails with "Not B2G. Can't launch app.".  What's a good way to do better here?  We could use a trait on Firefox desktop like "webappsLaunch: false", or something.  Does that seem like that a good idea?  Anyway, probably best in a followup.
Attachment #8519729 - Flags: review?(jryans) → review+
(Reporter)

Updated

4 years ago
Duplicate of this bug: 1077502
(Assignee)

Comment 10

4 years ago
(In reply to J. Ryan Stinnett [:jryans] from comment #8)
> Comment on attachment 8519729 [details] [diff] [review]
> v1
> 
> Review of attachment 8519729 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Works as intended for Chrome and iOS. (P.S. if you have a Mac but no iOS
> device, you can also connect to the iOS Simulator.)
> 
> For the Local Runtime, the play button is still enabled, but then fails with
> "Not B2G. Can't launch app.".  What's a good way to do better here?  We
> could use a trait on Firefox desktop like "webappsLaunch: false", or
> something.  Does that seem like that a good idea?  Anyway, probably best in
> a followup.

Yes. I saw that (that's why I had to change how errors are displayed).

Because we can't do much with the apps actor on Firefox desktop, we should not register this actor for the browser.
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
https://hg.mozilla.org/integration/fx-team/rev/8f922593c776
Flags: in-testsuite+
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/8f922593c776
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 36

Updated

5 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.