If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Pinned repos look like tabs but act like bookmarks (eg they don't save state)

RESOLVED DUPLICATE of bug 1125352

Status

Tree Management
Treeherder
P3
normal
RESOLVED DUPLICATE of bug 1125352
3 years ago
3 years ago

People

(Reporter: rillian, Unassigned)

Tracking

Details

Treeherder drops revision-specific fragment queries when switching between (treeherder ui) tabs. This is very confusing when e.g. comparing various try pushes to recent runs from main repos.

1. Visit treeherder link from try push, like https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=8608a0123e78
2. Click checkbox next to 'mozilla-beta' in the 'Repos' menu to add a tab.
3. Click on 'mozilla-beta' tab.
4. Click on 'try' tab to return to the try push.
5. The 'try' tab shows the current head of the try tree, not the specific revision link it previously showed.

Comment 1

3 years ago
The 'tabs' used to act like tabs, but due to UX and perf issues, that functionality was removed, leaving them as something more like bookmarks/favourites. I think the layout/UX could do better at making this clearer though. Alternatively we should come up with a better multi-repo in one tab story.

Updated

3 years ago
Summary: Tabs don't track revision-specific links → The pinned repos look like tabs but act like bookmarks (eg they don't save state)

Updated

3 years ago
OS: Linux → All
Priority: -- → P3
Hardware: x86_64 → All
Summary: The pinned repos look like tabs but act like bookmarks (eg they don't save state) → Pinned repos look like tabs but act like bookmarks (eg they don't save state)

Comment 2

3 years ago
Let's fix this as part of bug 1125352.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1125352
You need to log in before you can comment on or make changes to this bug.