[SMS] Moving from "Messages" to "Messaging Settings", causes transition issues

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
8 months ago

People

(Reporter: fmuyumba, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(tracking-b2g:+, b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [2.1-exploratory-3], URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8517014 [details]
logcat_20141104_1438.txt

Description:
Transition issues occur when a User moves from "Messages" to "Messaging Settings"
   
Repro Steps:
1) Update a Flame device to BuildID: 20141104001202
2) Launch ""Messages" App
3) Tap on ellipsis
4) Tap on "Settings"
5) Observe the transition process
  
Actual:
Transition issues occur when moving from "Messages" to "Messaging Settings"
  
Expected: 
Transition without issues
  
Environmental Variables:
Device: Flame 2.1 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141104001202
Gaia: 8b0cf889ae0d48a9eb7ecdcb9b67590de45cc5e5
Gecko: 388b03efe92d
Version: 34.0 
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
  
Repro frequency: 100%
See attached: video clip & logcat: http://youtu.be/UP8ZK6iulws
Flags: needinfo?(dharris)
Was recently fixed on settings in v2.2.

Arthur, can you dupe the bug?
Component: Gaia::SMS → Gaia::Settings
Flags: needinfo?(arthur.chen)
(Reporter)

Comment 2

4 years ago
This issue is reproducible on Flame 2.2(319mb)(KitKat)(Shallow Flash) and Flame 2.0(319mb)(KitKat)(Shallow Flash)

Result: Transition issues occur when a User moves from "Messages" to "Messaging Settings"

Environmental Variables:
Device: Flame 2.2(319mb)(KitKat)(Shallow Flash)
Build ID: 20141104040207
Gaia: 3c50520982560ccba301474d1ac43706138fc851
Gecko: 54d05732f29b
Version: 36.0a1 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

---------------------------------------------------------------------------------------------------------------

Environmental Variables:
Device: Flame 2.0(319mb)(KitKat)(Shallow Flash)
BuildID: 20141104000201
Gaia: fe2167fa5314c7e71c143a590914cbf3771905a8
Gecko: 241e51806687
Version: 32.0 
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
This issue has been fixed in master in bug 1007600.

Fred, could you try master again with full flash?
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(arthur.chen) → needinfo?(fmuyumba)
Resolution: --- → DUPLICATE
Duplicate of bug: 1007600
(Reporter)

Comment 4

4 years ago
There are still transition issues on Flame 2.2 Master(319mb)(KitKat)(Full Flash)

Result: When a User moves from "Messages" to "Messaging Settings", a blank (white) screen appears briefly before transitioning to "Messaging Settings"

Environmental Variables:
Device: Flame 2.2 Master(319mb)(KitKat)(Full Flash)
BuildID: 20141105160209
Gaia: 7918024c737c4570cacd784f267e28737ae05dea
Gecko: 2114ef80f6ae
Gonk: 48835395daa6a49b281db62c50805bd6ca24077e
Version: 36.0a1 
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
Flags: needinfo?(fmuyumba)
Since this issue is still occurring on 2.2 full flash it might not be the same bug. Should we reopen this bug Arthur?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris) → needinfo?(arthur.chen)
Reopen the bug. Note that the transition issue observed on 2.2 is different than the one on 2.1.
Status: RESOLVED → REOPENED
Flags: needinfo?(arthur.chen)
Resolution: DUPLICATE → ---
tracking-b2g: --- → +

Comment 7

8 months ago
Firefox OS is not being worked on
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.