need to remove whiteboard entries from lots of bugs

RESOLVED FIXED

Status

()

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: arich, Assigned: glob)

Tracking

Production
x86
Mac OS X
Dependency tree / graph

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
The kanbanize syncing script went wild and done an inclusion instead of an exclusion when components were commented out.  As a result, it went through and added whiteboard entries to a number of bugs it should not have. The cron job is no longer running at this point, so now I need to go back and clean things up (preferably without spamming everyone with more email).

Is it possible to remove the following whiteboard tag from all Infrastructure & Operation components that are NOT "RelOps" and "RelOps: Puppet"?

The regex for the whiteboard entry to remove is:

[kanban:engops:https://mozilla.kanbanize.com//ctrl_board/6/.*]

(note that you don't want a greedy .* there, just match up to the first "]" )

I'd also like to remove the following whiteboard entry from any bug that has it:

[kanban:engops:https://kanbanize.com/ctrl_board/6/.*]

(same note about the greedy match).
(Reporter)

Comment 1

4 years ago
Augh, the first match has an extra / in it. It should be:

[kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/.*]
moving out of administration as this requires development work (we need to write a script to automate those changes and not trigger bugmail).

:arr, do you have a time frame for when you'd like this done?
Component: Administration → General
Comment hidden (obsolete)
looks like i didn't grok comment 0 correctly (thanks callek):

SELECT 
    COUNT(*)
FROM
    bugs
WHERE
    (product_id = 107)
        AND NOT (component_id IN (1762 , 1766))
        AND (status_whiteboard LIKE '%[kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/%')

106

and

SELECT 
    COUNT(*)
FROM
    bugs
WHERE
    status_whiteboard LIKE '%[kanban:engops:https://kanbanize.com/ctrl_board/6/%'

444
per IRC this fix "by bmo admins" can likely happen in ~24-36 hours (and can't happen sooner than that). Just to establish expectations here too.
Created attachment 8517279 [details] [diff] [review]
1093952_1.patch
Assignee: nobody → glob
Status: NEW → ASSIGNED
Attachment #8517279 - Flags: review?(dkl)
(Reporter)

Comment 7

4 years ago
The more urgent request is the first regex because I've accidentally borked about 100ish bugs in someone else's component. Waiting a 2-3 days as callek indicates is probably fine since the things that was doing the borking has been turned off for the time being till we can review the code and figure out what went nuts.
Comment on attachment 8517279 [details] [diff] [review]
1093952_1.patch

My rusty perl thinks this is correctly what we want, thanks
Attachment #8517279 - Flags: feedback+
Comment on attachment 8517279 [details] [diff] [review]
1093952_1.patch

Review of attachment 8517279 [details] [diff] [review]:
-----------------------------------------------------------------

r=dkl as long as we do not care if the 
[kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/.*]
exists in other bugs that are not I & O bugs. Otherwise works fine.

::: extensions/BMO/bin/bug_1093952.pl
@@ +72,5 @@
> +    my $bug_id = $bug->{bug_id};
> +    print "bug $bug_id\n";
> +
> +    my $whiteboard = $dbh->selectrow_array(
> +        "SELECT status_whiteboard FROM bugs WHERE bug_id = ?",

Nit: You could just get the status_whiteboard in your main SELECT above and save the extra call.
Attachment #8517279 - Flags: review?(dkl) → review+
To ssh://gitolite3@git.mozilla.org/webtools/bmo/bugzilla.git
   247b01c..27ca752  master -> master
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
note- we won't be able to execute this script until it has been pushed to our production environment (bug 1094592).  due to the unusual timing of this push IT may not have someone available to action it.

the worst case scenario is sunday night us/pacific before this script can be deployed.
i'll see what i can do to get this out before then.
Depends on: 1094592
(Reporter)

Comment 12

4 years ago
Hm, I'm guessing that the resolved status means it's already been run? A bugzilla search still shows it in the whiteboard of the same bugs (sorry for the gargantuan link):

https://bugzilla.mozilla.org/buglist.cgi?o5=substring&list_id=11503800&o9=substring&o2=substring&status_whiteboard_type=allwordssubstr&v5=kanban%3Aengops%3Ahttps%3A%2F%2Fmozilla.kanbanize.com%2Fctrl_board%2F6%2F&v9=kanban%3Aengops%3Ahttps%3A%2F%2Fmozilla.kanbanize.com%2Fctrl_board%2F6%2F&o4=substring&status_whiteboard=kanban%3Aengops%3Ahttps%3A%2F%2Fmozilla.kanbanize.com%2Fctrl_board%2F6&v2=kanban%3Aengops%3Ahttps%3A%2F%2Fmozilla.kanbanize.com%2Fctrl_board%2F6%2F&v4=kanban%3Aengops%3Ahttps%3A%2F%2Fmozilla.kanbanize.com%2Fctrl_board%2F6%2F&f10=CP&f1=OP&o7=matches&v6=kanban%3Aengops%3Ahttps%3A%2F%2Fmozilla.kanbanize.com%2Fctrl_board%2F6%2F&o3=substring&f8=cf_crash_signature&f0=OP&v3=kanban%3Aengops%3Ahttps%3A%2F%2Fmozilla.kanbanize.com%2Fctrl_board%2F6%2F&o6=substring&f9=bug_file_loc&v7=%22kanban%3Aengops%3Ahttps%3A%2F%2Fmozilla.kanbanize.com%2Fctrl_board%2F6%2F%22&f4=alias&query_format=advanced&j1=OR&f3=component&f2=product&f11=CP&bug_status=UNCONFIRMED&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&f5=short_desc&v8=kanban%3Aengops%3Ahttps%3A%2F%2Fmozilla.kanbanize.com%2Fctrl_board%2F6%2F&f6=status_whiteboard&component=Account%20Requests&component=Change%20Requests&component=Community%20IT&component=Community%20IT%3A%20Hosting&component=Community%20IT%3A%20Infrastructure&component=Community%20IT%3A%20Others&component=Infrastructure%3A%20DNS&component=Infrastructure%3A%20IRC&component=Infrastructure%3A%20LDAP&component=Infrastructure%3A%20Mail&component=Infrastructure%3A%20OpenVPN&component=Infrastructure%3A%20Other&component=Infrastructure%3A%20Puppet&component=Infrastructure%3A%20Tools&component=Infrastructure%3A%20Zimbra&component=MOC%3A%20Incidents&component=MOC%3A%20Problems&component=MOC%3A%20Projects&component=MOC%3A%20Service%20Requests&component=Mozilla%20VPN%3A%20ACL%20requests&component=Mozilla%20VPN%3A%20Support%20requests&component=NetOps&component=NetOps%3A%20DC%20ACL%20Request&component=NetOps%3A%20DC%20Carrier&component=NetOps%3A%20DC%20Other&component=NetOps%3A%20DC%20Port%20Configurations&component=NetOps%3A%20Office%20ACL%20Requests&component=NetOps%3A%20Office%20Carrier&component=NetOps%3A%20Office%20Other&component=NetOps%3A%20Office%20Wireless&component=NetOps%3A%20Other&component=NetOps%3A%20Projects&component=Servicedesk&component=Storage&component=Telecom&component=Tools&component=WebOps%3A%20Community%20Platform&component=WebOps%3A%20Engagement&component=WebOps%3A%20Inventory&component=WebOps%3A%20IT-Managed%20Tools&component=WebOps%3A%20Labs&component=WebOps%3A%20Other&component=WebOps%3A%20Product%20Delivery&component=WebOps%3A%20Socorro&component=WebOps%3A%20SSL%20and%20Domain%20Names&f7=content&product=Infrastructure%20%26%20Operations&o8=substring
(In reply to Amy Rich [:arich] [:arr] from comment #12)
> Hm, I'm guessing that the resolved status means it's already been run? A
> bugzilla search still shows it in the whiteboard of the same bugs (sorry for
> the gargantuan link):

For BMO code, RESOLVED means the code has been committed to the repo but is not necessarily on production yet. In this case as stated in comment 11, we are just waiting for an admin to have time to run the script itself on production to do the cleanup work. Worst case sunday night.

dkl
the script has been run (bug 1095294), crazy long url returns no results now.
You need to log in before you can comment on or make changes to this bug.