session resume failed after upgrading to firefox 34 beta 5 and even beta 6

RESOLVED WORKSFORME

Status

()

Firefox
Session Restore
RESOLVED WORKSFORME
3 years ago
a year ago

People

(Reporter: vega109, Unassigned)

Tracking

34 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0
Build ID: 20141027152126

Steps to reproduce:

Update from firefox 34 beta 4 to firefox 34 beta 5 and even firefox beta 6 (with about firefox method or with .exe file)


Actual results:

1. Beta 5 or beta 6 refused to resume session after update. (just a blank tab)
2. All the tiles of my new tab were missing. (became blank tiles)
3. Synchronization failed.
4. I shift back to version 34 beta 4 with the same profile and all things works fine.

I also found one person with the same symptoms on the web (he uses firefox-35.0a1)
http://forums.mozillazine.org/viewtopic.php?f=23&t=2876819


Expected results:

Normal operation just as previous update.
(Reporter)

Updated

3 years ago
Severity: normal → critical
Component: Untriaged → Session Restore

Comment 1

3 years ago
Can you create a fresh profile with 34b4 (see https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles) and force the update to the latest beta. Do you see the same issue?
Flags: needinfo?(vega109)
(Reporter)

Comment 2

3 years ago
(In reply to Loic from comment #1)
> Can you create a fresh profile with 34b4 (see
> https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-
> firefox-profiles) and force the update to the latest beta. Do you see the
> same issue?

@Loic
Many thanks for your advise. I have created a fresh profile with 34b4 and force the update to the latest beta. The problem seemed resolved and the synchronization seemed to be fine. However, some of my add-ons disappeared and I have to re-install these add-ons and import some of the add-ons settings.

This is the first time for me to do this because it never occurred to me that the update was so painful. I still can't figure out why my update from 34b4 to 34 b6 cause this problem, although this condition resolved.

I will keep my old profile data and use the new profile and see what happened if the latest beta version came out.
Flags: needinfo?(vega109)
(Reporter)

Updated

3 years ago
Severity: critical → normal

Comment 3

3 years ago
This new profile was just a test, you can delete it. Firefox has a reset feature to fix issues with a broken profile due to add-ons or prefs, see https://support.mozilla.org/en-US/kb/reset-firefox-to-fix-most-problems

It will keep your essential private data, but remove the prefs and add-ons.
Of course, you can move some add-ons manually from your current to new profile.
(Reporter)

Comment 4

3 years ago
@Loic
Many thanks for your help. I really appreciated it. I have moved the whole settings(themes, preferences, essential private data, add-ons, add-ons settings) to the new profile this afternoon and it works fine currently. 

Although I still don't know what happened to my old profile(I have used this profile for about 10 years and it never occurred to me that this update would cause such a tragedy, although sometimes incompatible add-ons would happen after upgrade), I will test this old profile in the new version in the future and see what happens.

Comment 5

3 years ago
The problem persists in 34 release.
I observed it with several betas of 34 as well.
The session large, with over 200 tabs across 3 windows.
I have AdblockPlus and TabMixPlus installed.

On other computers/profiles everything works Ok.
(Reporter)

Comment 6

3 years ago
@spy@mozilla.mbox.ath.cx

Many thanks for your experience sharing.
vega109,
are you still seeing these problems when using a current  version?
Flags: needinfo?(vega109)
(Reporter)

Comment 8

a year ago
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #7)
> vega109,
> are you still seeing these problems when using a current  version?

No, it works fine after using new profile.

Many thanks for concerning about this issue.

Updated

a year ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(vega109)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.