Closed Bug 1093980 Opened 5 years ago Closed 5 years ago

Intermittent test_FrameSelection.html | videoWidth has correct final value - got 320, expected 160

Categories

(Core :: Audio/Video, defect)

36 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla39
Tracking Status
firefox37 --- wontfix
firefox38 --- fixed
firefox39 --- fixed
firefox-esr31 --- unaffected

People

(Reporter: KWierso, Assigned: bholley)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

10:34:30 INFO - 2076 INFO TEST-START | /tests/dom/media/mediasource/test/test_FrameSelection.html
10:34:30 INFO - ++DOMWINDOW == 117 (14A21400) [pid = 3720] [serial = 3678] [outer = 14189000]
10:34:31 INFO - 2077 INFO TEST-PASS | /tests/dom/media/mediasource/test/test_FrameSelection.html | fetchWithXHR load uri='seek.webm' status=200
10:34:31 INFO - 2078 INFO TEST-PASS | /tests/dom/media/mediasource/test/test_FrameSelection.html | currentTime has correct initial value
10:34:31 INFO - 2079 INFO TEST-PASS | /tests/dom/media/mediasource/test/test_FrameSelection.html | videoWidth has correct initial value
10:34:31 INFO - 2080 INFO TEST-PASS | /tests/dom/media/mediasource/test/test_FrameSelection.html | videoHeight has correct initial value
10:34:31 INFO - 2081 INFO TEST-PASS | /tests/dom/media/mediasource/test/test_FrameSelection.html | fetchWithXHR load uri='seek_lowres.webm' status=200
10:34:31 INFO - 2082 INFO TEST-PASS | /tests/dom/media/mediasource/test/test_FrameSelection.html | Video currentTime at target
10:34:31 INFO - 2083 INFO TEST-UNEXPECTED-FAIL | /tests/dom/media/mediasource/test/test_FrameSelection.html | videoWidth has correct final value - got 320, expected 160
10:34:31 INFO - 2084 INFO TEST-UNEXPECTED-FAIL | /tests/dom/media/mediasource/test/test_FrameSelection.html | videoHeight has correct final value - got 240, expected 120
10:34:31 INFO - 2085 INFO TEST-PASS | /tests/dom/media/mediasource/test/test_FrameSelection.html | Video currentTime at target
10:34:31 INFO - 2086 INFO TEST-UNEXPECTED-FAIL | /tests/dom/media/mediasource/test/test_FrameSelection.html | videoWidth has correct final value - got 320, expected 160
10:34:31 INFO - 2087 INFO TEST-UNEXPECTED-FAIL | /tests/dom/media/mediasource/test/test_FrameSelection.html | videoHeight has correct final value - got 240, expected 120
10:34:31 INFO - 2088 INFO TEST-OK | /tests/dom/media/mediasource/test/test_FrameSelection.html | took 957ms
10:34:31 INFO - ++DOMWINDOW == 118 (14A6FC00) [pid = 3720] [serial = 3679] [outer = 14189000]
10:34:31 INFO - 2089 INFO TEST-START | /tests/dom/media/mediasource/test/test_HaveMetadataUnbufferedSeek.html
10:34:31 INFO - ++DOMWINDOW == 119 (0FEC8E00) [pid = 3720] [serial = 3680] [outer = 14189000]
10:34:33 INFO - 2090 INFO TEST-OK | /tests/dom/media/mediasource/test/test_HaveMetadataUnbufferedSeek.html | took 1298ms
10:34:33 INFO - ++DOMWINDOW == 120 (14AE2A00) [pid = 3720] [serial = 3681] [outer = 14189000]
10:34:33 INFO - 2091 INFO TEST-START | /tests/dom/media/mediasource/test/test_MediaSource.html
10:34:33 INFO - ++DOMWINDOW == 121 (14A20600) [pid = 3720] [serial = 3682] [outer = 14189000]
Nothing in the spec says this should hold, and it holds less often when we move
invalidation to happen at the end of seeking.
Attachment #8573462 - Flags: review?(matt.woodrow)
Blocks: 1135170
Landed this rpending=mattwoodrow because it's test-only and blocks landing bug 1135170. Happy to make any desired changes retroactively, and will hold myself to it.
Regression testing a problem led me to this patch on inbound.  Specifically, weather.com either doesn't render completely, will get a 'not responding message' and I have to close Fx or it crashes on it's own.

Running in safe-mode I have no problems with weather.com which is strange.  I don't believe it's an add-on that is at fault since I deleted the extension folder on my live system and still have the problem. 


Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:39.0) Gecko/20100101 Firefox/39.0
(In reply to Gary [:streetwolf] from comment #9)
> Regression range:
> 
> Good: https://hg.mozilla.org/integration/mozilla-inbound/rev/dc86a4e16519
> 
> Bad:  https://hg.mozilla.org/integration/mozilla-inbound/rev/cb5ec48a3391

Well, this patch is test-only, so I doubt this is the culprit. There are various other changes in that range, including the seeking changes in bug 1135170. I'm a bit skeptical that those are at fault, because a cursory glance at weather.com suggests it doesn't use html audio/video elements.

Do you have a link to the crash report?
I don't get any crash reports.  Even if I did are they of any use because there are no debug symbols?
As I stated weather.com works in safe-mode.  As you know safe-mode not only disables add-ons it also changes prefs particular the graphic ones.  Could be this and one of the patches.
Created a new profile and have the same problems with weather.com.  I notice the graphics options are the same as on my live system but very different when I run in safe-mode.  I did get a crash report:

https://crash-stats.mozilla.com/report/index/a762e4e8-03d0-4a36-8d99-7c1fd2150307
https://hg.mozilla.org/mozilla-central/rev/cb5ec48a3391
Assignee: nobody → bobbyholley
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla39
Attachment #8573462 - Flags: review?(matt.woodrow) → review+
You need to log in before you can comment on or make changes to this bug.