Settings app to follow text selection pattern

RESOLVED FIXED in 2.2 S2 (19dec)

Status

defect
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: hochang, Assigned: arthurcc)

Tracking

unspecified
2.2 S2 (19dec)
x86
macOS
Dependency tree / graph

Firefox Tracking Flags

(feature-b2g:2.2+, tracking-b2g:+)

Details

Attachments

(2 attachments)

Reporter

Description

5 years ago
* Input fields (input areas, input dialogs and search fields) are the only Building Blocks with selectable text. 

* HTML elements like buttons or links, or events like ontouchstart or onclick, should trigger the action when tapped rather than triggering text selection.
Reporter

Comment 1

5 years ago
The Gecko work is close to completion, the remaining part is to fix test case failures then pref it on in m-c bug 1092888. After the bug landed, text selection and cut/copy/paste can be triggered in apps on both editable and non-editable elements.

Gaia per app work in v2.2 is to follow UX guideline and leverage CSS -moz-user-select https://developer.mozilla.org/en-US/docs/Web/CSS/user-select to make certain elements non-selectable.

Before Gecko is pref on in m-c, Gaia can manually switch it on by the following two pref to test in advance:
pref("selectioncaret.enabled", on);
pref("selectioncaret.noneditable", on);
Reporter

Comment 2

5 years ago
This is a 2.2 feature.
feature-b2g: 2.2? → 2.2+
Reporter

Updated

5 years ago
Duplicate of this bug: 1092971
blocking-b2g: --- → backlog
QA Whiteboard: [COM=SystemPlatform]
EJ, could you help review this simple patch? Thanks.
Attachment #8537082 - Flags: review?(ejchen)
Assignee: nobody → arthur.chen
Status: NEW → ASSIGNED
Comment on attachment 8537082 [details]
link to https://github.com/mozilla-b2g/gaia/pull/26814

Arthur, I think we have to whitelist down needed input types instead of make all of them selectable, please check my comments on GitHub, thanks !
Attachment #8537082 - Flags: review?(ejchen)
Comment on attachment 8537082 [details]
link to https://github.com/mozilla-b2g/gaia/pull/26814

Comment addressed. Please help review it again, thanks.
Attachment #8537082 - Flags: review?(ejchen)
Thanks, EJ!

master: 58734e8a48157f99d5b733412b600c2e04c954fe
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Reporter

Updated

5 years ago
Target Milestone: --- → 2.2 S2 (19dec)
Depends on: 1131852
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.