Add gtk3 builds on taskcluster

RESOLVED WORKSFORME

Status

Release Engineering
General Automation
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: glandium, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
I'm currently using the elm disposable branch for gtk3 builds, but it would be better to have them on "normal" automation, now, with a few limitations:
- They would be hidden for the moment, and only run on the integration branches and m-c.
- They would not trigger tests on m-c/integration
- They would be available in more flavors on try
- They could trigger any test suite on try

I think it would be reasonable to have m-c/integration only do linux64 gtk3 builds, while allowing all of linux,linux64,linux-debug,linux64-debug on try.

Configuration-wise, they would be the exact same as the current linux builds, but using a different tooltool manifest, that could be named gtk3.manifest instead of releng.manifest.
(Reporter)

Comment 1

3 years ago
<nthomas|away> glandium: would be worth running that by sheriffs, and defining what tier support it has
It would be good as far as Fedora is going to deploy Gtk3 Firefox in rawhide (a.k.a. Fedora 22) and we're looking to ship in there.
(Reporter)

Comment 3

3 years ago
(In reply to Martin Stránský from comment #2)
> It would be good as far as Fedora is going to deploy Gtk3 Firefox in rawhide
> (a.k.a. Fedora 22) and we're looking to ship in there.

I'd say that's waaaaay too early for that.
(In reply to Mike Hommey [:glandium] from comment #3)
> (In reply to Martin Stránský from comment #2)
> > It would be good as far as Fedora is going to deploy Gtk3 Firefox in rawhide
> > (a.k.a. Fedora 22) and we're looking to ship in there.
> 
> I'd say that's waaaaay too early for that.

Fedora 22 is going out in ~ 6 months, I think it's enough time :)
If they're hidden by default, I'm not sure why this involves our team.
(Reporter)

Comment 6

3 years ago
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #5)
> If they're hidden by default, I'm not sure why this involves our team.

They would be hidden by default... for now, until the last orange on the build is sorted out, at which point it would become visible.
Unhiding them would entail filing a new bug in the Treeherder component where we could then weigh whether they meet visibility standards or not. Simply turning the jobs on in production hidden by default isn't something our team has a stake in.
https://wiki.mozilla.org/Sheriffing/Job_Visibility_Policy
(Reporter)

Updated

3 years ago
Depends on: 1151508
Summary: Add gtk3 builds to buildbot → Add gtk3 builds on taskcluster
We're closing to having a bunch of the tests suites green. What's needed to turn this on for those suites?
(Reporter)

Comment 9

3 years ago
Most importantly, the builds are green (they used to be orange), so we can already start with this. Many tests are green too, and it would be useful to keep them green, avoiding regressions (which do happen because those builds aren't part of the normal CI, but are on a separate branch).
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.