Closed Bug 1094093 Opened 5 years ago Closed 2 years ago

[Flame][v2.1][Calendar]Back to day/week view from an event detail page, slide down the page, it will enter blank page.

Categories

(Firefox OS Graveyard :: Gaia::Calendar, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:-, tracking-b2g:+, b2g-v2.1 unaffected, b2g-v2.2 unaffected, b2g-master affected)

RESOLVED WONTFIX
blocking-b2g -
tracking-b2g +
Tracking Status
b2g-v2.1 --- unaffected
b2g-v2.2 --- unaffected
b2g-master --- affected

People

(Reporter: liuke, Unassigned, NeedInfo)

Details

Attachments

(4 files)

Attached file logcat_1643.txt
[1.Description]:
After back to day/week view from an event detail page, slide down the  page, it will enter blank page.
Found time:16:43
See attachment:1643.mp4 and logcat_1643.txt

[2.Testing Steps]: 
1.Launch Calendar.
2.Switch to day/week view, then create a new event.
3.After save it, tap "<" to back day/week view.
4.Slide down page.

[3.Expected Result]: 
4.The blank page should not show.

[4.Actual Result]: 
4. You can slide to blank page.

[5.Reproduction build]: 
Gaia-Rev        027a7de0c95320cea0579bfd1a4ceef3e9038f34
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/ffecb2be228b
Build-ID        20141103001220
Version         34.0

[6.Reproduction Frequency]: 
Always Recurrence,5/5
Attached video 1043.MP4
Summary: [MGSEI][Flame][v2.1][Calendar]Back to day/week view from an event detail page, slide down the page, it will enter blank page. → [Flame][v2.1][Calendar]Back to day/week view from an event detail page, slide down the page, it will enter blank page.
This bug has been verified to fail on Flame 2.2, but verified not happen on latest Flame 2.1 build.

Steps:
1.Launch Calendar.
2.Switch to day/week view.
3.Slide down page.

[3.Expected Result]: 
3.The blank page should not show.

[4.Actual Result]: 
3. You can slide to blank page.

Note: This issue only exist in first launch Calendar, you can kill the calendar process to reproduce it.

See attachment: 1718.MP4 and logcat_1718.txt
Reproducing rate: 3/5
Found time:17:18

Flame 2.1 version:
Gaia-Rev        17c7ad2e4919a994f0844239b483116090412dee
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-2g34_v2_1/rev/39dfb662c82a
Build-ID        20141225001203
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141225.035108
FW-Date         Thu Dec 25 03:51:19 EST 2014
Bootloader      L1TC00011880

Flame 2.2 version:
Gaia-Rev        ab41c35eed35404b632a4841714b81b56364ba32
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/2acb12da9813
Build-ID        20141225010202
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141225.043916
FW-Date         Thu Dec 25 04:39:27 EST 2014
Bootloader      L1TC00011880
Flags: needinfo?(echang)
Attached file logcat_1718.txt
Attached video 1718.MP4
Hi Lance, The STR is kind of vague, I cannot reproduce the bug with the steps, could you try to update this, thanks. And the 1043.MP4 seems to be not for this bug.
Flags: needinfo?(echang) → needinfo?(liuke)
(In reply to Eric Chang [:ericcc] [:echang] from comment #5)
> Hi Lance, The STR is kind of vague, I cannot reproduce the bug with the
> steps, could you try to update this, thanks. And the 1043.MP4 seems to be
> not for this bug.

Hi Eric,
    This bug only exists in Flame 2.2(See 1718.mp4), Flame 2.1 verified not happen on 20141225001203 build. Details please see comment 2, thanks.
Flags: needinfo?(liuke) → needinfo?(echang)
1. Launch Calendar.
2. Start to slide the page upward when switching from Month to Week/Day view and before it stops scrolling to the current time.
3. There is a brief moment when you can see a blank page there.
QA Whiteboard: [COM=Gaia::Calendar]
Flags: needinfo?(echang)
Hi Gareth, Could you help to check the scrolling effect, thanks.
Flags: needinfo?(gaye)
This bug has been verified to fail on Flame 3.0, but it is verified not happen on latest Flame 2.1 & 2.2 build.

Issue steps:
1.Launch Calendar.
2.Switch to day/week view, then create a new event.
3.After save it, tap "<" to back day/week view.
4.Slide down page.

Expected Result: 
Flame 3.0: 4.The blank page should not show.

Actual Result: 
Flame 3.0: 4. You can slide to blank page.
Flame 2.1 & 2.2: 4.The blank page can not show.

Note: This issue only exist in first launch Calendar, you can kill the calendar process to reproduce it.

Fail rate:
Flame 2.1 & 2.2: 0/5
Flame 3.0:Reproducing rate: 5/5

Flame 2.1 version:
Build ID               20150209001212
Gaia Revision          4a14bb118d55f3d15293c2ff55b7f29f9b0bfcdb
Gaia Date              2015-02-06 20:37:32
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/6cbe28d0bb8c
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150209.035242
Firmware Date          Mon Feb  9 03:52:53 EST 2015
Bootloader             L1TC000118D0

Flame 2.2 version:
Build ID               20150209002504
Gaia Revision          e827781324cbde91d2434b388f5dead3303a85ee
Gaia Date              2015-02-06 20:54:14
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/0552759956d3
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150209.040038
Firmware Date          Mon Feb  9 04:00:51 EST 2015
Bootloader             L1TC000118D0

Flame 3.0 version:
Build ID               20150209010211
Gaia Revision          0d7b35f23402c4cb29bca6b98280fec48a196dec
Gaia Date              2015-02-08 20:44:20
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/3436787a82d0
Gecko Version          38.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150209.045655
Firmware Date          Mon Feb  9 04:57:06 EST 2015
Bootloader             L1TC000118D0
Flags: needinfo?(whsu)
QA Whiteboard: [COM=Gaia::Calendar] → [COM=Gaia::Calendar][MGSEI-Triage+]
[Blocking Requested - why for this release]:

I also saw the similar symptom on browser app.
Bad user experience. Nominate it.
blocking-b2g: --- → 3.0?
Flags: needinfo?(whsu)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
blocking-b2g: 2.5? → -
tracking-b2g: --- → +
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Suspect this is still happening if Lance is talking about the delay before the hours appear further down the page. Moving to tracking+
Firefox OS is not being worked on
Status: REOPENED → RESOLVED
Closed: 5 years ago2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.