Closed Bug 1094195 Opened 7 years ago Closed 7 years ago

(ios) Integrate the login viewcontroller

Categories

(Firefox for iOS :: Firefox Accounts, defect)

All
iOS 7
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: st3fan, Assigned: bnicholson)

References

Details

Attachments

(1 file)

45 bytes, text/x-github-pull-request
st3fan
: review+
Details | Review
The login viewcontroller that was created during the iOS sprint needs to be integrated in the firefox-ios project.

In the app delegate we need to check if the user is logged in or not and then show either the login screen or the landing page.

The login screen needs to call the fake REST API to check login credentials. (There is a GET /1.0/profile API)

These credentials need to be stored in the native Keychain so that they can be used in the other viewcontrollers that grab data. (Those currently have credentials hardcoded to a test account)
Assignee: nobody → bnicholson
Attached file Pull request
Attachment #8518450 - Flags: review?(sarentz)
Attachment #8518450 - Flags: review?(sarentz) → review+
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1094478
Group: mozilla-employee-confidential
Component: General → Firefox Accounts
OS: Linux → iOS 7
Product: Firefox for Android → Firefox for iOS
Hardware: x86_64 → All
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.