Please select the previous search terms when clicking in the search input, or just don't autofill it

RESOLVED DUPLICATE of bug 1062828

Status

Mozilla Developer Network
Search
--
minor
RESOLVED DUPLICATE of bug 1062828
3 years ago
3 years ago

People

(Reporter: julienw, Unassigned)

Tracking

Details

(Reporter)

Description

3 years ago
STR:
* click on the search box
* search for "input", press enter
* click on the first result
* click on the search box

Expected:
* when I type something, I want this to be searched

Actual:
* when I click on the search box, the previous search is autofilled, and the cursor stays at the end. As a result, I always end up _appending_ my new search.
Because the search box look empty when I click on it, I don't even look at it when I type. As a result, I'm bit by this issue every single time I use the search functionality, even that I know about the issue.
Sheppy says he gets bit by this every time when searching on MDN.  Would be an easy fix?
Severity: normal → minor
Flags: needinfo?(dwalsh)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1062828
Flags: needinfo?(dwalsh)
You need to log in before you can comment on or make changes to this bug.