All users were logged out of Bugzilla on October 13th, 2018

Status

()

--
minor
VERIFIED WORKSFORME
17 years ago
17 years ago

People

(Reporter: dr, Assigned: hyatt)

Tracking

({perf})

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: wfm, URL)

(Reporter)

Description

17 years ago
The <iframe> containing thumbnail images at the site:

  http://sleepy.at/~dr/portfolio

is scrolled by the arrows using some simple javascript. I've filed bug 109421 
against libpr0n (for the case where you sit there and don't do anything to the 
page), but in addition, the CPU spikes when you try to scroll the iframe.
(Reporter)

Comment 1

17 years ago
This should block 21762, jst's tracking bug for DHTML perf.
Blocks: 21762
Keywords: perf

Comment 2

17 years ago
Clicking and holding on the little red arrows make my CPU peek at about 33%
using Mozilla Build 2001101117 on a PIII-733 Win2k system.  The page on IE6
sometimes peeks as high as 40% when scrolling.

Comment 3

17 years ago
-> dom0
Component: Browser-General → DOM Level 0
QA Contact: doronr → desale
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.1

Comment 4

17 years ago
Dan, I'm not seeing any more than ~40% cpu use on either 500MHz linux or win32.
In fact, it scrolls quite byootifully!

(is this wfm?)
Whiteboard: wfm

Comment 5

17 years ago
using build 2001122203 on win2k with a PIII,500MHZ on win2k also displays this 
smooth and fine :)
wfm ?

Comment 6

17 years ago
Indeed!
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 7

17 years ago
Hmm... WFM, heh?  This concerns me a bit.

Is the goal for Mozilla to be adequate or beat IE's numbers?

The following observations were done using build 2001122509 on Win2k (SP2) with 
a PII 266 and a 4 meg Matrox Millenium II video card.

For instance, in the case of the DHTML demo at the URL in the URL field, 
Mozilla does display the animation pretty well.  There are very minor hiccups 
(short freezes) as the images are scrolled but, for the most part, Mozilla 
displys the animations pretty well.  In fact, the scrolling is pretty close to 
the same in both Mozilla and IE5.5 SP2.  However, IE only spikes at 75% CPU and 
is generally in the upper 50's to middle 60's whereas Mozilla spikes at 92% CPU 
and is generally in the mid to upper 80's.  

So, looking at this, Mozilla's performance seems adequate, but does not beat 
out IE.  Maybe this should be under some other general performance bug (and if 
someone knows of that bug, please let me know) but I'd like to know if the 
Mozilla team has any stated performance goals and whether they are aiming to 
make Mozilla an adequate performer or are actively striving to beat the 
competition?

Jake

Comment 8

17 years ago
Performance on an Athlon 700 (512k cache model) with 128 and a Voodoo3 (no
reasonable system based performance bottlenecks) and no apps running on 0.9.7
flatly sucks. Sure, it sucks in IE too, but I don't that's not unusual. The fact
that it's poor in Mozilla should be of concern though... Recomminding re-opening...

Comment 9

17 years ago
Seriously. On a 500MHz Linux and a 500MHz win2k and 450MHz Mac OS 9, I don't 
seeing _anything_ wrong with how this dhtml (which makes the whining comments 
about IE **** irrelevant).
No longer blocks: 21762
Status: RESOLVED → VERIFIED
Target Milestone: mozilla1.1 → Future

Comment 10

17 years ago
Seriously. On win98 it's slow. Rather than saying people are whining, a better,
more constructive use of time might be asking people for more detailed ysem
configurations to see what differences may be at fault for slowing the display.
Here, with a minimum of background processes, Win98SE, build 2001122803, the
page works great when the images aren't yet loaded. Once they're all loaded, it
slows noticebly. ideas?

Comment 11

17 years ago
this CPU spike issue is probably caused by Mozilla painting more frequently than
IE unnecessarily. Another issue could be the video card. hoju@visi.com think you
can profile the testcase or get someone with similar hardware/setup to profile this?

Comment 12

17 years ago
basic,

I'd be happy to profile this test case on my system, but what kind of profile 
are you looking for?  My observations were based on watching cpu usage in the 
Win2k task manager.  Is there anything specific you can recommend that I use to 
get a more scientific analysis of usage of system resources?  I'm just not 
experienced with that kind of stuff.  I'm really just going off observation.  
Any help would be appreciated :-)

As for John Morrison's comments, what's eating you today?  I'm not using a 
500Mhz machine, I'm using a 266Mhz machine and IE uses less CPU (please compare 
apples to apples).  In addition, I asked a simple question that you flatly 
ignored choosing instead to use a personal attack calling me a "whiner" (nice 
argumentative skills and attitude).  Thirdly, you removed this bug from the 
DHTML tracking bug out of spite or something.  Seriously, in the future, try to 
avoid using Bugzilla as your personal anger management tool.

Jake

Comment 13

17 years ago
Okay, I retract the adjective 'whining' [note: not the noun], which comes off
a bit harsh, but is far short of a "personal attack".  (Although speaking of
personal attacks, see comment #12, above).

If someone is interested in profiling this example, digging into the code and
producing a patch, then, great, go ahead. However, I have also now tested on
266MHz win98/rh6.2/macos9.2 and they all perform smoothly on those
systems. Yes, the CPU spikes in mozilla; it does in IE6 on win98 as well
[although the spike in IE6 is lower primarily because it doesn't scroll the
images as quickly]. But it doesn't "suck" in either mozilla or IE6 for these
systems.

It is possible that this depends on some specific hardware configuration
(video card, ram, ...). In fact, if it "sucks" on a given system in both IE
and mozilla, then that pretty clearly suggests a hardware issue.

Comment 14

17 years ago
hoju@visi.com: what we need is a profile of what part of the code is causing
this. You probably would need a debug build...

Comment 15

17 years ago
John,

Retraction accepted and apologies for any comments of my that could be 
construed as a personal attack (although I called it like I saw it rather than 
using it as an excuse to avoid a question).  However, If you read comment #7, 
which I don't think you really did, I think you would realize that I plainly 
stated that performance was relatively decent on my PII 266 and, in fact, 
pretty much equivalent to IE (not sure how performance could "suck" with a 
faster processor as in comment #8???).  I also asked a valid question about CPU 
usage which, I think, you finally answered (after some cajoling) in comment 
#13.  The final question I asked which has yet to be addressed directly is 
whether a goal of Mozilla is to have better DHTML performance than IE (or any 
other browser, for that matter) on an equivalent platform (such as me running 
both Mozilla and IE on the same 266Mhz machine).  If this is simply a naive 
question, please let me know.  I don't claim to be an expert in these matters. 
However, if you believe this is so, please provide some reasoning for this or 
direct me to a resource that explains it.  All I want is for Mozilla to be the 
best damned browser out there.  Let's not let that fact get lost in these 
discussions.

jake
You need to log in before you can comment on or make changes to this bug.