Restore previous session after not saving previous session adds new tab on left

RESOLVED INVALID

Status

RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: mozilla, Unassigned)

Tracking

SeaMonkey 2.30 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0 SeaMonkey/2.30
Build ID: 20141013232806

Steps to reproduce:

1. Launch SeaMonkey, open some tabs, open record or remember them.
2. Exit. At the prompt, answer "Save and Close".
3. Relaunch SeaMonkey and verify that the same tabs are open as before you closed.
4. Exit again, but this time answer "Close Browser" at the prompt.
5. Relaunch SeaMonkey and issue menu command Go | Restore Previous Session.
6. Verify that the same tabs are open as before you closed.


Actual results:

An additional tab is added on the left side of the browser window. In my case it is a Google search window.


Expected results:

All the tabs that were opened during the previous session should be restored, no more, no less.

Comment 1

4 years ago
Not able to reproduce in a new, clean Profile.

But that is not to say that this does not occur.
There have been enough times that I've said to myself, "didn't I close that tab before quitting last time?", only to have it, or a set of what I would have thought would have been closed tabs reopen.  These would all be tabs/places I'd revisit anyhow, so I've never really paid much attention to know if it was me being forgetful or if unexpected tabs were in fact opening from Session Restore.

> In my case it is a Google search window.

Is Google set as your Home Page or anything like that?
Is Google a page you have visited in the past (duh)?
Is it always Google that is the odd page appearing?
If you change your Home Page from Google to www.mozilla.org, is it then that page that incorrectly gets restored?

Perhaps if you have some minimalist sessesionstore.json that you're able to reproduce with?

FF is different & quirky enough that I find it hard to make sense of what it is doing or what the intended behavior is or should be.  But I'll note that FF looks to append pages when doing History | Restore Previous Session, where SeaMonkey would replace existing.

I'll also note that restoring from a crash may be a little different again.
(Reporter)

Comment 2

4 years ago
Thanks for pointing these things out, therube. You were correct.
Restore Previous Session ADDS the previous session tabs to whatever tabs are already open. In my case, I hadn't noticed this because my home page was set as a single tab with the Google web search page, that is, it wasn't something memorable. So, every time I closed and reopened the browser it added a new tab with the Google web search page. The way to avoid this is to click the Save and Close button on exiting.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.