Closed Bug 1094300 Opened 5 years ago Closed 4 years ago

[Homescreen]While on Edit page of Homescreen, icons take a long time to paint while scrolling (easy to cause checkerboarding)

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(tracking-b2g:+, b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 unaffected)

RESOLVED WONTFIX
tracking-b2g +
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- affected
b2g-v2.2 --- unaffected

People

(Reporter: rmead, Unassigned)

References

()

Details

(Keywords: regression, Whiteboard: [2.1-exploratory-3][systemsfe])

Attachments

(1 file)

Attached file Flame2.1logcat.txt
Description:
While on the Homescreen Edit page, if you quickly scroll, the icons take a long time to paint.
   
Prereq:
Have lots of apps arranged on the homescreen to give it a good amount of vertical scroll room
   
Repro Steps:
1) Update a Flame device to BuildID: 20141104001202
2) Long press one of the apps on the homescreen to go into Edit page
3) Quickly scroll to the bottom of the page then back to the top
  
Actual:
Icons coming onto the screen take a few seconds before they are painted
  
Expected: 
Icons scroll onto the screen without any noticeable lag
  

Environmental Variables:
Device: Flame 2.1 (319mb)(KitKat)(Shallow Flash)
BuildID: 20141104001202
Gaia: 8b0cf889ae0d48a9eb7ecdcb9b67590de45cc5e5
Gecko: 388b03efe92d
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

  
Repro frequency: 100%
See attached: logcat, video - http://youtu.be/mIWGYcT-sCU
This issue does NOT occur on Flame 2.0(319mb) and Flame 2.2(319mb)

When on Homescreen Edit page, if you rapidly scroll through the icons, the icons will show up fine.

Flame 2.0

Device: Flame 2.0(319mb)(KitKat)(Shallow Flash)
BuildID: 20141104000201
Gaia: fe2167fa5314c7e71c143a590914cbf3771905a8
Gecko: 241e51806687
Version: 32.0 (2.0)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Flame 2.2

Device: Flame 2.2(319mb)(KitKat)(Shallow Flash)
Build ID: 20141104040207
Gaia: 3c50520982560ccba301474d1ac43706138fc851
Gecko: 54d05732f29b
Version: 36.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
[Blocking Requested - why for this release]:

Nominating to block on 2.1. This is a regression, bad UX because app icons disappear briefly, and a similar bug (bug 1042772) was blocked on it before.
blocking-b2g: --- → 2.1?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
Whiteboard: [2.1-exploratory-3] → [2.1-exploratory-3][systemsfe]
Not blocking for broken functionality. revisiting in 2.2 esp for lower memory devices
blocking-b2g: 2.1? → backlog
tracking-b2g: --- → +
bug is no longer a blocker, removing regressionwindow-wanted tag (which are not done on non-blockers)
QA Whiteboard: [QAnalyst-Triage+]
[Tweaking summary to mention "checkerboarding", to enhance bug discoverability & reduce likelihood of dupes being filed (I almost just now filed one). (checkerboarding is our general name for the phenomena of delayed painting of scrolled-in content).]
Summary: [Homescreen]While on Edit page of Homescreen, icons take a long time to paint while scrolling → [Homescreen]While on Edit page of Homescreen, icons take a long time to paint while scrolling (easy to cause checkerboarding)
blocking-b2g: backlog → ---
Mass update: Resolve wontfix all issues with legacy homescreens.

As of 2.6 we have a new homescreen and having these issues open is confusing. All issues will block bug 1231115 so we can use that to re-visit any of these if needed.
Blocks: 1231115
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.