Problems with P/R approval workflow.

RESOLVED FIXED

Status

Webtools
Air Mozilla
P1
normal
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: sbohan, Assigned: richard, NeedInfo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8517575 [details]
Request___Air_Mozilla___Mozilla__in_Video.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141002185629

Steps to reproduce:

Created an event and submitted it. 
Was still "pending approval" up until yesterday
Now I check it (the event is scheduled for tomorrow) and it says "details missing"
I open the event and ALL of the details are missing
ALSO - a previous event that was up there is now gone


Actual results:

See above


Expected results:

Waiting for approval or request for more info. Got neither. Event is scheduled for tomorrow and I need to know if I need to cancel it
Assignee: nobody → richard
Your screenshot has two event titles. Which one is it that you're focusing on in this case.
(Reporter)

Comment 2

4 years ago
The event I am referring to is the Community Tiles Brief which is scheduled for tomorrow. The Doc Searls event happened in June and was supposed to be part of a blog post.
Created attachment 8517599 [details]
Screenshot 2014-11-05 10.41.47.png

Summary view. All looks well. 

I'm a superuser so I can see your Summary page. 

The event is scheduled for tomorrow at 14:30 eastern time. 
The new title is "Community Tiles Brown Bag".
What I don't understand is, why is it scheduled for tomorrow but it was at the same time rejected by PR with the note "Please indicate the goal of making this public and who the audience is." from "Justin O'Kelly". 

It's two weird things go on here:

1) Was it approved and scheduled and THEN rejected by PR? How is that even possible?

2) When you load your home page of requests (https://air.mozilla.org/requests/) it says "Details missing" when it should say "Approved and scheduled". There are no details missing so that's quite possibly a bug. 


Richard, can you understand what's going on with the approval piece?
(Reporter)

Comment 5

4 years ago
No idea to question 1, nor did I get notification from PR. Will ping O'Kelly now. 

thanks for the follow-up Peter!
(Assignee)

Comment 6

4 years ago
It looks like a bug.    I think "Approved" only indicates that we accepted the request.  It wasn't showing up in the calendar.   

I've changed it to "Contributor" which eliminates the need for P/R approval and it's showing now.

Sean, you should contact Justin O'Kelly (jokelly@mozilla.com) and see if you can convince him to change his mind about making it public.   His comment when he rejected it was: "Please indicate the goal of making this public and who the audience is".   That should be appearing on your home page of requests.  The fact that it isn't is clearly a bug.
(Assignee)

Updated

4 years ago
Summary: Filed a request for Air.Mozilla last week, was pending approval, no notification, now "details missing" - this was supposed to be for tomorrow - help? → Problems with P/R approval workflow.
(Assignee)

Comment 7

4 years ago
Additional problems with the P/R approval workflow:  

1 - Changing a P/R rejected event from Public to Contributor does not automatically change it to scheduled.  It is necessary to hit the "Reconsider" button on the P/R approval page and mark it approved there (with a comment explaining what you're doing).

2 - After hitting the "Reconsider" Button, only the last comment is visible on the P/R approval page, not the comment left by the P/R staffer who rejected it.
(Assignee)

Updated

4 years ago
Component: Other → Air Mozilla
Product: Air Mozilla → Webtools
Version: unspecified → Trunk
(Assignee)

Updated

4 years ago
Priority: -- → P1
(Assignee)

Comment 8

4 years ago
Sean, can you scroll down to the bottom of that Request Summary screen and post another screen shot?

Thanks!

-- Richard
(Assignee)

Updated

4 years ago
Flags: needinfo?(sbohan)
(Assignee)

Comment 9

3 years ago
Approval workflow now topic driven.  Completely changed.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.