Status

--
enhancement
VERIFIED WONTFIX
17 years ago
7 years ago

People

(Reporter: contacto, Assigned: paulkchen)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
A page loads.  User is reading it.  During this, mozilla is checking links that
derive from this page and marking with a different color those who are broken
(404) errors.  So, looking at the page loaded the user can see without clicking
which links will or not work when clicked.  Instead of marking bad links with
colors a message can appear floating when the mouse is over the broken link.

Comment 1

17 years ago
This would generate tons of network traffic on pages with many links and slow
things down to a crawl. Usually links aren't even broken.
Can't say i like the idea but it sounds like an RFE, not a bug.
Changing severity.
Severity: normal → enhancement
Maybe related to functionality in bug 91388. I think this is a bad idea,
too--this will generate a tremendous amount of useless HTTP traffic, like the
slashdot effect for Mozilla.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: WONTFIX?

Comment 3

17 years ago
Yeah, this would be very bad.  wontfix.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX
v
Status: RESOLVED → VERIFIED
*** Bug 147593 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Whiteboard: WONTFIX?

Comment 6

17 years ago
It is obviously not a good idea to create additional traffic, but this feature
could be found in a content sensitive menu or something. Personally I would like
to use this feature while using search engines.

Http HEAD request would do the job. Dozens of pictures and animations are
downloaded every time user goes to a average web page, a couple of http HEAD
requests would not be such a bad thing IMHO.

Comment 7

17 years ago
*** Bug 153765 has been marked as a duplicate of this bug. ***

Comment 8

17 years ago
I do not seek a check for all links on a page, but it is just about the behaviuor what happens when you click a link.
IE does it as follows: click on broken link -> link appears as visited
Moz does: click on broken link -> link is not visited.
The latter makes more sense, but i'd like a way to distuinguish between not visited (new) links, and links that didn't work. Those last coulb be having text-decoration :linethrough krijgen. 
It shouldn't check all links, but it should just respond to links clicked by the user. I'd say this behavior should limit traffic instead of increasing it
Product: Core → Mozilla Application Suite

Updated

7 years ago
Flags: blocking-seamonkey2.0.15?

Updated

7 years ago
Flags: blocking-seamonkey2.0.15?
You need to log in before you can comment on or make changes to this bug.