resizer (e.g. on textarea) needs to be drawn in RTL form when writing-mode is vertical-rl

RESOLVED FIXED in mozilla36

Status

()

defect
RESOLVED FIXED
5 years ago
3 years ago

People

(Reporter: jfkthame, Assigned: jfkthame)

Tracking

(Blocks 1 bug)

unspecified
mozilla36
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Currently, the rendering of a resizer is sensitive to direction (LTR vs RTL), so that when it appears at the bottom-left of a (horizontal) RTL textarea, it renders mirrored from the bottom-right version. But on a vertical-rl textarea, although it appears at the bottom left, it still renders as it would at the bottom right.

In vertical writing-mode, the rendering of the resizer should depend on the block direction instead of the inline direction, so that instead of LTR vs RTL, it will depend on vertical-lr vs vertical-rl.
This was a bit confusing, as the rendering of the resizer is handled completely differently when scrollbars are present vs when they're absent. But AFAICT this appears to work properly in either case. (Only tested on OS X so far, in conjuction with a bunch of other pending vertical-mode patches.)
Attachment #8517734 - Flags: review?(roc)
Assignee: nobody → jfkthame
Status: NEW → ASSIGNED
Comment on attachment 8517735 [details] [diff] [review]
Reftests for display of resizer on vertical-lr and vertical-rl textareas.

Review of attachment 8517735 [details] [diff] [review]:
-----------------------------------------------------------------

::: layout/reftests/writing-mode/1094434-1-ref.html
@@ +12,5 @@
> +  writing-mode: vertical-lr;
> +}
> +.vrl {
> +  writing-mode: vertical-rl;
> +}

Remove these unused classes
Attachment #8517735 - Flags: review?(roc) → review+
It turns out this fails on Linux, but that's because RTL resizer rendering is broken there already. I've filed bug 1094845 about that.
sorry had to backout for Android Test failures like https://treeherder.mozilla.org/ui/logviewer.html#?job_id=3850318&repo=mozilla-inbound
Flags: needinfo?(jfkthame)
Argh. Yes, that's clearly been caused by the patch here. (Guess I didn't tryserver enough platforms!) :( I'll look into it.
Flags: needinfo?(jfkthame)
https://hg.mozilla.org/mozilla-central/rev/4a65cacf8a37
https://hg.mozilla.org/mozilla-central/rev/9772eacfaf03
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Depends on: 1094845
You need to log in before you can comment on or make changes to this bug.