customising the toolbar puts the browser in a broken state (broken devtools and customise ui)

RESOLVED DUPLICATE of bug 1096763

Status

RESOLVED DUPLICATE of bug 1096763
4 years ago
3 months ago

People

(Reporter: glob, Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(firefox35? affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
when i select 'customise', a new tab opens with the location about:customizing however the page is blank.

mattN helped track down the issue over irc, please read the logs at:
http://logs.glob.uno/?c=fx-team#c178656

deleting my browser.uiCustomization.state preference restored the customise functionality.

here's the value of .state before i cleared it:

user_pref("browser.uiCustomization.state", "{\"placements\":{\"PanelUI-contents\":[\"edit-controls\",\"zoom-controls\",\"new-window-button\",\"e10s-button\",\"privatebrowsing-button\",\"save-page-button\",\"print-button\",\"history-panelmenu\",\"fullscreen-button\",\"find-button\",\"preferences-button\",\"add-ons-button\",\"webide-button\"],\"addon-bar\":[\"addonbar-closebutton\",\"status-bar\"],\"PersonalToolbar\":[\"personal-bookmarks\"],\"nav-bar\":[\"urlbar-container\",\"search-container\",\"developer-button\",\"bookmarks-menu-button\",\"downloads-button\",\"lpt_lastpass-compact-btn\"],\"TabsToolbar\":[\"tabbrowser-tabs\",\"new-tab-button\",\"alltabs-button\"]},\"seen\":[\"abp-toolbarbutton\"],\"dirtyAreaCache\":[\"PersonalToolbar\",\"nav-bar\",\"TabsToolbar\",\"PanelUI-contents\",\"addon-bar\"],\"currentVersion\":1,\"newElementCount\":0}");

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:35.0) Gecko/20100101 Firefox/35.0 (devedition)
[Tracking Requested - why for this release]: DevEdition new feature breaks customization mode

I guessed the problem was the webide-button placement in the menu panel and glob confirmed that after resetting customizations, placing the webide-button in the panel breaks customize mode.
Blocks: 1056923
status-firefox35: --- → affected
tracking-firefox35: --- → ?
Component: Toolbars and Customization → Developer Tools: WebIDE
Summary: "customise" results in a blank page (due to bad browser.uiCustomization.state?) → Customise mode results in a blank page if webide-button is in the menu panel

Comment 2

4 years ago
OSX non-retina?
(Reporter)

Comment 3

4 years ago
(In reply to Paul Rouget [:paul] (slow to respond. Ping me on IRC) from comment #2)
> OSX non-retina?

retina laptop with non-retina external monitor.  both screens display the same behaviour.
Do we have STR for this? I just customized the WebIDE button into my panel and had no problems entering customize mode, both after moving and after a restart.

If anybody is able to reliably reproduce this, I'll bet there'd be interesting stuff in Browser Console that we could use to debug...

Comment 5

4 years ago
I can't reproduce either.

Comment 6

4 years ago
(In reply to Mike Conley (:mconley) - Needinfo me! from comment #4)
> Do we have STR for this? I just customized the WebIDE button into my panel
> and had no problems entering customize mode, both after moving and after a
> restart.
> 
> If anybody is able to reliably reproduce this, I'll bet there'd be
> interesting stuff in Browser Console that we could use to debug...

Has anyone tried actually closing a profile, replacing the user_pref value with the one cited in comment #0, reopening the browser and then clicking customize?
Yep, that's how I tried to reproduce it, with no luck.
Created attachment 8518282 [details]
Browser Console Output

(In reply to Mike Conley (:mconley) - Needinfo me! from comment #4)
> If anybody is able to reliably reproduce this, I'll bet there'd be
> interesting stuff in Browser Console that we could use to debug...

See the IRC logs (linked in comment 0). I didn't see anything interesting in the Browser Console output. I'm attaching them here now.

I couldn't reproduce this with current Aurora or the Gum branch. It's possible glob was on an older build.

Comment 9

4 years ago
(In reply to Matthew N. [:MattN] (focused on Loop) from comment #8)
> Created attachment 8518282 [details]
> Browser Console Output
> 
> (In reply to Mike Conley (:mconley) - Needinfo me! from comment #4)
> > If anybody is able to reliably reproduce this, I'll bet there'd be
> > interesting stuff in Browser Console that we could use to debug...
> 
> See the IRC logs (linked in comment 0). I didn't see anything interesting in
> the Browser Console output. I'm attaching them here now.
> 
> I couldn't reproduce this with current Aurora or the Gum branch. It's
> possible glob was on an older build.

That log looks like glob enters customize through some other means than the panel (eg: toolbar context menu). That could make a difference in when the widget is built and what assumptions that makes?

glob: can you still reproduce on a recent build?
Flags: needinfo?(glob)
(Reporter)

Comment 10

4 years ago
(In reply to :Gijs Kruitbosch from comment #9)
> glob: can you still reproduce on a recent build?

at the time i was using the most recent build available.
just grabbed an update and i'm no longer able to reproduce this issue.

thanks for taking the time to investigate, closing as R/WFM
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(glob)
Resolution: --- → WORKSFORME
(Reporter)

Comment 11

4 years ago
reopening as this is actually still happening.

the STR are:
1. ensure browser.uiCustomization.state is empty
2. customise the toolbar by removing icons
3. restart firefox

following the restart:
- i can no longer open the customise ui
- the 'browser toolbox' and 'connect' menuitems are missing from the 'web developers' menu

if i quit firefox, edit prefs.js to remove browser.uiCustomization.state and restart the browser things are back working again.

markh has reporting having similar experiences on his mac with regards to broken develop tools (but has not experienced a broken customise ui).
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Summary: Customise mode results in a blank page if webide-button is in the menu panel → customising the toolbar puts the browser in a broken state (broken devtools and customise ui)

Comment 12

4 years ago
(In reply to Byron Jones ‹:glob› from comment #11)
> reopening as this is actually still happening.
> 
> the STR are:
> 1. ensure browser.uiCustomization.state is empty
> 2. customise the toolbar by removing icons


which icons? I bet this is a dupe of bug 1096763
(Reporter)

Comment 13

4 years ago
indeed.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1096763

Updated

3 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.