Closed Bug 1094633 Opened 5 years ago Closed 5 years ago

[Contenteditable] the cursor position is off when the element is empty but has generated content

Categories

(Core :: DOM: Editor, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 904846

People

(Reporter: julienw, Unassigned)

References

Details

Attachments

(1 file)

Attached file editable.html
STR:
1. open the attachment
2 [review]. put the cursor in the white zone (contenteditable area)
=> notice it's correctly located
3. push the button
4. put the cursor in the white zone again
=> notice the cursor is badly located
5. start typing some text
=> notice the text is now correctly positioned

This happens also without any positioning CSS properties but it's more off with these CSS properties.

This impairs the SMS application in Firefox OS since we started doing MMS and using contenteditable fields (so, since version v1.1). We need to take care to always leave a <br> element so that the cursor is correctly located. It starts to be difficult with the cut&paste capability we'll have in v2.2.

Ehsan, I've been told you're the one to needinfo here?

Asking for blocker status on v2.2 because this is becoming more difficult to workaround with the cut&paste capability.
Flags: needinfo?(ehsan.akhgari)
Blocks: 1094000
Flags: needinfo?(masayuki)
Oleg found bug 904846, likely same issue.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(masayuki)
Flags: needinfo?(ehsan.akhgari)
Resolution: --- → DUPLICATE
Duplicate of bug: 904846
blocking-b2g: 2.2? → ---
You need to log in before you can comment on or make changes to this bug.