[Flame][Settings]"Connecting to device" is always displayed when we turn off Geolocation and try to connect device in website.

RESOLVED WONTFIX

Status

Firefox OS
FindMyDevice
RESOLVED WONTFIX
4 years ago
4 months ago

People

(Reporter: Alissa(leave from Mozilla), Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(tracking-b2g:backlog, b2g-v2.1 affected, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [2.2-flame-reduced-run])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8518019 [details]
1.png

[1.Description]:"Connecting to device" is always displayed when we turn off Geolocation and try to connect device in website.
see attachments:1.png

[2.Testing Steps]: 
1.Sign in fiefox account and enable find my device.
2.Turn off Geolocation.
3.Sign in firefox account on website.

[3.Expected Result]: 
3.There should be a map without loctaion of device displayed.

[4.Actual Result]: 
3."Connecting to device" always be displayed,but device had been connected.

[5.Reproduction build]: 
Gaia-Rev        154da5e17029a51002d5d9b7df39563d509edde6
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/3b0c3580a58d
Build-ID        20141105001204
Version         34.0

[6.Reproduction Frequency]: 
Always Recurrence,5/5
(Reporter)

Updated

4 years ago
status-b2g-v2.1: --- → affected
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: --- → affected
Flags: needinfo?(dharris)
Whiteboard: [2.2-flame-reduced-run]
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)

Comment 1

3 years ago
Hi William,
Could you help with it? Thanks!
This issue can be repro on latest build of Flame 2.1/2.2/3.0, after disable the Geolocation and go to "find.firefox.com", "Connecting to device" always be displayed, but device had been connected.

Flame 2.1 build:
Build ID               20150227002636
Gaia Revision          5d3479fdd438412adee4452720856b6b771fe5cd
Gaia Date              2015-02-25 18:20:09
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/0390c73a827b
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150227.035555
Firmware Date          Fri Feb 27 03:56:06 EST 2015
Bootloader             L1TC000118D0

Flame 2.2 build:
Build ID               20150227002521
Gaia Revision          eb6a5ac9081d3962198e0f4520b0743d716d7a27
Gaia Date              2015-02-26 17:25:22
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c8a38dcfbebc
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150227.035943
Firmware Date          Fri Feb 27 03:59:54 EST 2015
Bootloader             L1TC000118D0

Flame 3.0 build:
Build ID               20150227010229
Gaia Revision          7512026a377271a0cade12d70846557f0bc7781c
Gaia Date              2015-02-26 19:06:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/c7968255c1ea
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150227.044026
Firmware Date          Fri Feb 27 04:40:36 EST 2015
Bootloader             L1TC000118D0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
status-b2g-master: --- → affected
Flags: needinfo?(whsu)

Updated

3 years ago
Summary: [Flame][v2.1][Settings]"Connecting to device" is always displayed when we turn off Geolocation and try to connect device in website. → [Flame][Settings]"Connecting to device" is always displayed when we turn off Geolocation and try to connect device in website.

Comment 2

3 years ago
[Blocking Requested - why for this release]:

This is a common issue.
Firstly, I think we can check FMD server side log to find the root cause.
If this is a client side issue, I suggest to fix issue on latest branch or uplift patches to the appropriate branches if necessary.

* Please help dispatch this bug to the right person if someone sees the message.
blocking-b2g: --- → 3.0?
Component: Gaia::Settings → FindMyDevice
Flags: needinfo?(whsu)
Not blocking 2.5
blocking-b2g: 2.5? → ---
[Tracking Requested - why for this release]:
Per comment 3
tracking-b2g: --- → backlog

Comment 5

4 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.