Closed Bug 1094721 Opened 7 years ago Closed 3 years ago

[Keyboard]Keyboard can't pop up automatically after entering some page which need inputting.

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.0 affected, b2g-v2.0M affected, b2g-v2.1 affected, b2g-v2.2 affected)

RESOLVED WONTFIX
Tracking Status
b2g-v2.0 --- affected
b2g-v2.0M --- affected
b2g-v2.1 --- affected
b2g-v2.2 --- affected

People

(Reporter: huayu.li, Unassigned)

References

Details

Attachments

(3 files)

Attached file logcat.txt
[1.Description]:
Keyboard can't pop up automatically after entering some page which need inputting.
Occurence time:9:29
See attachments:VID_0006_Compress.MP4.logcat.txt

[2.Testing Steps]: 
1.Open settings -> Go to wifi.(Or other page which need inputting,such as email,contact)
2.Tap one wifi.
Note:Keyboard can pop up atfer enter message edit view.

[3.Expected Result]: 
Keyboad can pop up automatically in the page which need inputting.

[4.Actual Result]: 
Enter wifi connecting view,but we need manually tap the input box to call the keyboard.

[5.Reproduction build]: 
FLAME:
Gaia:      812ae91c9708a9116cdb2d15cc02a43ded862a78
Gecko:   https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/f92e54a91038
Build-ID:   20141021160201
Version:    32.0
WOODDUCK:
Gaia:   ff24db33f8ebb275b200030035b851701b617b80
Gecko:  e7df4dde2d9dbedee942333d34eaea2afe32bebc
Build-ID:  20141022050313
Version:  32.0
[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7. Other Note]:
Keyboard can pop up atfer entering message edit view.
Attached video VID_0006_Compress.MP4
Summary: [MGSEI][Woodduck][Flame][v2.0][Keyboard]Keyboard can't pop up automatically after entering some page which need inputting. → [Woodduck][Flame][v2.0][Keyboard]Keyboard can't pop up automatically after entering some page which need inputting.
Summary: [Woodduck][Flame][v2.0][Keyboard]Keyboard can't pop up automatically after entering some page which need inputting. → [Woodduck][Flame][v2.0][flame2.1][Keyboard]Keyboard can't pop up automatically after entering some page which need inputting.
To invoke the keyboard, it depends on the app itself to do focus on the input field.
So, move this issue to settings app.
Component: Gaia::Keyboard → Gaia::Settings
This issue exist on Flame 2.2:
Gaia-Rev        3554ea9504046646b4679e3a61317c49fc55ca87
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/67c42c076393
Build-ID        20141228010205
Version         37.0a1
Device-Name     flame
FW-Release      4.4.2
Reproduce rate 5/5
Attch log: logcat22.txt
Happen time:4:31
Attached file logcat22.txt
QA Whiteboard: [COM=Gaia::Settings]
Hi Hermes,
Is this by design behavior?
Thanks
Group: woodduck-confidential
Flags: needinfo?(hcheng)
(In reply to Josh Cheng [:josh] from comment #5)
> Hi Hermes,
> Is this by design behavior?
> Thanks

I don't think so. However, this is a really old bug, and I think we need to see if it still exists.

Alissa, could you help here?
Flags: needinfo?(hcheng) → needinfo?(huayu.li)
Hi hermers, This issue can be reproduced on latest build of flame2.2&master and nexus5 2.2&master.
Rate:5/5

Device: Flame 2.2 (Affected)
Build ID               20150702162501
Gaia Revision          2d6cbec3a4004bb770ecbadbba83f86b95365e56
Gaia Date              2015-07-02 13:40:55
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/b465f8d7254f
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150702.195016
Firmware Date          Thu Jul  2 19:50:27 EDT 2015
Bootloader             L1TC000118D0

Device: Flame master (Affected)
Build ID               20150702160209
Gaia Revision          722028715a56a03f327e2e70f2c32dcb6d819d4c
Gaia Date              2015-07-02 08:51:28
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/2f25351c5b05
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150702.193535
Firmware Date          Thu Jul  2 19:35:46 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus5 2.2 (Affected)
Build ID               20150702162501
Gaia Revision          2d6cbec3a4004bb770ecbadbba83f86b95365e56
Gaia Date              2015-07-02 13:40:55
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/b465f8d7254f
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150702.194637
Firmware Date          Thu Jul  2 19:46:53 EDT 2015
Bootloader             HHZ12f

Device: Nexus5 master (Affected)
Build ID               20150702160209
Gaia Revision          722028715a56a03f327e2e70f2c32dcb6d819d4c
Gaia Date              2015-07-02 08:51:28
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/2f25351c5b05
Gecko Version          42.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150702.192214
Firmware Date          Thu Jul  2 19:22:31 EDT 2015
Bootloader             HHZ12f
Flags: needinfo?(huayu.li)
Summary: [Woodduck][Flame][v2.0][flame2.1][Keyboard]Keyboard can't pop up automatically after entering some page which need inputting. → [Keyboard]Keyboard can't pop up automatically after entering some page which need inputting.
Ok, thanks.
NI keyboard developer.
Flags: needinfo?(timdream)
Valid bug but not related to keyboard, see comment 2.
Flags: needinfo?(timdream)
Thanks. Transfer NI to Settings app developer.
Flags: needinfo?(ehung)
(In reply to Alissa from comment #0)
> ...
> [2.Testing Steps]: 
> 1.Open settings -> Go to wifi.(Or other page which need inputting,such as
> email,contact)

Not sure if it's Settings specific issue, from bug description, it says any app with input field being focused after loading the page. I suspect it's a racing issue such as JS try to set focus before the page getting global focus, so it failed.

Hermes, could you confirm that it's not only happened in Settings but also other apps?

and is it a regression? However, this bug is really old so we probably can't get a regression range...
Flags: needinfo?(ehung) → needinfo?(hcheng)
(In reply to Evelyn Hung [:evelyn] from comment #11)
> (In reply to Alissa from comment #0)
> > ...
> > [2.Testing Steps]: 
> > 1.Open settings -> Go to wifi.(Or other page which need inputting,such as
> > email,contact)
> 
> Not sure if it's Settings specific issue, from bug description, it says any
> app with input field being focused after loading the page. I suspect it's a
> racing issue such as JS try to set focus before the page getting global
> focus, so it failed.
> 
> Hermes, could you confirm that it's not only happened in Settings but also
> other apps?
> 
> and is it a regression? However, this bug is really old so we probably can't
> get a regression range...

Actually, I cannot reproduce this issue at other apps for now.

After recheck the video (attachment 8518056 [details]), I think the description of this bug is not correct and clear. It should point that the keyboard does not pop up after user clicks into a 'WPA-PSK' wifi which requires user to input password. So, we need to find out if this is as design for Settings app.
Flags: needinfo?(hcheng)
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.