In month view, show events in adjacent months

VERIFIED FIXED

Status

P3
enhancement
VERIFIED FIXED
17 years ago
7 years ago

People

(Reporter: flacco002, Assigned: mikeypotter)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
The month view usually shows a few days prior to and following the active month.
 Instead of showing empty date cells, it would be useful to show the events in
those days too.
(Assignee)

Comment 1

17 years ago
This would be a nice feature.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Taking
Assignee: mikep → caillon
OS: Linux → All
Priority: -- → P3
Hardware: PC → All
Status: NEW → ASSIGNED
(Assignee)

Comment 3

17 years ago
You need to do a few things:
1. Figure out what day the first box is.
2. Figute out what day the last box is.
3. Send a request to the back end to get all the events for that range.  This
will return all the events, with a property of display date that will tell you
when they show up.
4. Figure out how to display them.
If you have questions, irc.mozilla.org #calendar or post them here.

Comment 4

17 years ago
This deals with Views, and is in the requirements doc. Blocks 122660. Sorry for
the spam.
Blocks: 122660
(Assignee)

Comment 5

17 years ago
*** Bug 139765 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 6

16 years ago
Reassigning to default owner to see if someone can take this on.
Assignee: caillon → mikep
Status: ASSIGNED → NEW

Comment 7

16 years ago
See bug 154779
(Assignee)

Comment 8

16 years ago
*** Bug 170456 has been marked as a duplicate of this bug. ***

Comment 9

16 years ago
OK, I can take this bug.
There were no fonction to easily send a request to the back end to get all the
events for the range of DISPLAY date.
So, I added a function that I called "getEventsDisplayForRange" because the 
name "getEventsForRange" were already used. 
If we compare the names used for the family of fonctions getEventsForMonth,
getEventsForWeek..., I think that It would be better if the old
function getEventsForRange were rename getRawEventsForRange, and the
new function were called getEventsForRange.
I prepared two patches:
- one for the file calendarEvent.js including this new function
- one for the file monthView.js with allows to show the events of 
adjacent months.

This file also correct a bug on the localization of the dots of repeating
events (when the day box is too small to display all events). All the dots
were located in the box of the first occurrence of a repeating event.

Comment 10

16 years ago
Created attachment 111389 [details] [diff] [review]
patch to add a function getEventsDisplayForRange

concerne the file calendarEvent.js
Asking for review.

Comment 11

16 years ago
Created attachment 111390 [details] [diff] [review]
patch of monthView.js

asking for review.

Updated

16 years ago
Attachment #111389 - Flags: first-review?(mikep)
(Assignee)

Comment 12

16 years ago
This is fixed in cvs, I'll make a new build this afternoon with it.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Attachment #111389 - Flags: first-review?(mikep)

Comment 13

16 years ago
I tried the fixed downloads. It works fine for me. Thanx for the patch!

Comment 14

16 years ago
VERIFIED
Status: RESOLVED → VERIFIED
The bugspam monkeys have been set free and are feeding on Calendar :: Sunbird Only. Be afraid for your sanity!
QA Contact: colint → sunbird

Comment 16

7 years ago
not working in lightning 1.0 - when printing one month the first days of the following month are printed, however without the appointments of these days. either add the appointments or don't print the first days of the following month (I vote for the last - if I select e.g. december for printing then I expect a software to just print december).
This bug has quite some spiderwebs, I think we should track the issue in the new bug you opened. Thanks for looking into this one though!
You need to log in before you can comment on or make changes to this bug.