[bluetooth] Sending image to Mac fails

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: wilsonpage, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
STEPS

1. Open gallery
2. Share an image via blueooth
3. Choose Mac from found devices
4. Accept pair request

RESULT

Error notification: 'Failed to send'. Blue notification stripe never stops animation.

EXPECTED

File should begin sending to paired device. I should be notified once complete.

Comment 1

4 years ago
Hi Wilson,

Did you enable bluetooth sharing on your Mac as following?
https://wiki.mozilla.org/B2G/Bluetooth#FAQ

5. Why can't I send a file to or receive a file from my Mac?
If you would like to share files to Mac, the file-transfer function should be enabled beforehand.
1. Click the Bluetooth icon at the top-right corner of the screen
2. Select "Open Bluetooth Preferences" from the drop down menu, then click the "Sharing Setup..." button at the bottom right of the dialog that opens
3. Make sure the "Bluetooth Sharing" checkbox is enabled.
Please see http://support.apple.com/kb/PH10786 for more information.
Flags: needinfo?(wilsonpage)
(Reporter)

Comment 2

4 years ago
The instructions are lightly out of date for Yosemite. These instructions helped me find the Bluetooth Sharing option [1]. Although even after ticking 'Bluetooth Sharing', the results we very similar.

VIDEO: https://www.youtube.com/watch?v=dqByPA29TQw

[1] http://support.apple.com/kb/PH18714
Flags: needinfo?(wilsonpage)
Created attachment 8518702 [details]
Mac_BtFileTransfer.png
Hi Wilson,
Thank you for uploading the video.

I followed the STR on Mac pro with Yosemite 10.10 and I got the same result.
However, Bluetooth file transfer worked fines after I selected a different folder at option [Folder for accepted items] #Attachment 8518702 [details].

According to http://support.apple.com/kb/PH18714, the default folder should be the Downloads folder, but it seems that if you don't select a folder manually, it would hit a bug on OS X Yosemite.

Would you mind to select a folder at #Attachment 8518702 [details] and try it again ?
Flags: needinfo?(wilsonpage)
See Also: → bug 1090876
(Reporter)

Comment 5

4 years ago
jaliu: You instructions worked perfect, thanks! Wow Apply really ballsed up the UX on that one. I hope we can add your guidance to the official Firefox OS docs :)
Flags: needinfo?(wilsonpage)
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
Duplicate of this bug: 1090876

Updated

3 years ago
See Also: → bug 1223329
You need to log in before you can comment on or make changes to this bug.