Closed Bug 1094884 Opened 5 years ago Closed 5 years ago

Intermittent browser_styleeditor_fetch-from-cache.js | A promise chain failed to handle a rejection: - Protocol error (unknownError): [Exception... "Unexpected error" nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)" location: "JS frame :: resource://gre/modul

Categories

(DevTools :: Style Editor, defect)

All
Linux
defect
Not set

Tracking

(firefox34 unaffected, firefox35 unaffected, firefox36 fixed, firefox-esr31 unaffected)

RESOLVED FIXED
Firefox 36
Tracking Status
firefox34 --- unaffected
firefox35 --- unaffected
firefox36 --- fixed
firefox-esr31 --- unaffected

People

(Reporter: cbook, Assigned: pbro)

References

()

Details

(Keywords: intermittent-failure)

Attachments

(1 file, 1 obsolete file)

Ubuntu VM 12.04 fx-team opt test mochitest-e10s-devtools-chrome

https://treeherder.mozilla.org/ui/logviewer.html#?job_id=1115703&repo=fx-team

05:50:21 INFO - 2749 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/styleeditor/test/browser_styleeditor_fetch-from-cache.js | A promise chain failed to handle a rejection: - Protocol error (unknownError): [Exception... "Unexpected error" nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)" location: "JS frame :: resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/server/actors/highlighter.js :: CanvasFrameAnonymousContentHelper.prototype._insert :: line 443" data: no]
Patrick, do you have cycles to look into this? Otherwise, can you suggest someone else who does? This is very frequent and will need to be disabled otherwise.
Flags: needinfo?(pbrosset)
Really sorry Ryan, but I don't have time immediately to look into this as I'm looking into making the browser/devtools/inspector e10s compliant.
I'm going to suggest Heather, as she's worked on the style-editor the most, but as far as I know, she's also pretty busy with e10s at the moment.
Heather, what do you think? Should we temporarily disable this test?
Flags: needinfo?(pbrosset) → needinfo?(fayearthur)
(In reply to TBPL Robot from comment #87)
> 2797 INFO TEST-UNEXPECTED-FAIL |
> chrome://mochitests/content/browser/browser/devtools/styleeditor/test/
> browser_styleeditor_fetch-from-cache.js | A promise chain failed to handle a
> rejection:  - Protocol error (unknownError): [Exception... "Unexpected
> error"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame ::
> resource://gre/modules/commonjs/toolkit/loader.js ->
> resource://gre/modules/devtools/server/actors/highlighter.js ::
> CanvasFrameAnonymousContentHelper.
Hmm, I didn't originally see that, part of the errors are related to the new highlighter implementation I landed last week.
I'll take a look at why this would fail.
But the thing is the highlighter-related errors come before the test tab is created, so well before the highlighter is instantiated. It almost looks like its an error message from the previous test, when running them in a test suite.
I'm updating and building on my linux VM to try and reproduce (since it seems to be failing mostly on linux).
I think this should take care of the highlighter errors in the failing test.
My assumption for this fix is that calling doc.insertAnonymousContent (which is what the highlighter does) when the document isn't fully ready will fail. 

And since the test is navigating to a test URL but not waiting for the page to be loaded, this might happen.

This patch fixes the test.
I'm not seeing intermittent failures locally anymore with this. I haven't been able to push to try yet though, since its closed.
Assignee: nobody → pbrosset
Attachment #8520240 - Flags: review?(fayearthur)
Clearing the NI? flag.
Flags: needinfo?(fayearthur)
Comment on attachment 8520240 [details] [diff] [review]
bug1094884-intermittent-browser_styleeditor_fetch-from-cache.js.patch

Review of attachment 8520240 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good. Can you just throw that method in head.js?
Attachment #8520240 - Flags: review?(fayearthur) → review+
Thanks for the review Heather.
I moved the new function over to head.js in this new version.
Attachment #8520240 - Attachment is obsolete: true
Attachment #8520258 - Flags: review+
Also pushed to try with a patch to enable e10s testing: https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=5dfcd667a643
I'm not seeing this particular test failing so far in my try pushes.
Even if I'm not yet entirely sure this fixes the issue, it makes sense to land it still as it can only help make the test more stable.
Looks like the patch hit the spot, the test doesn't seem to be failing intermittently anymore.
Removing the leave-open keyword.
Keywords: leave-open
Well played!
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 36
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.