Closed Bug 1094928 Opened 8 years ago Closed 8 years ago

Periodic B2G crash in IndexedDB code

Categories

(Core :: Storage: IndexedDB, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1081703

People

(Reporter: kats, Unassigned)

References

Details

Attachments

(1 file)

I have a Flame flashed with latest master and if I just leave it idle it seems to reboot periodically (every ~5 minutes or so). I attached gdb to the root process and got a backtrace, will attach it in a sec. Points to IndexedDB code, it looks like.
It looks like the mRequest at [1] is non-null but also not a valid pointer, because calling AddRef on it is crashing.

[1] http://mxr.mozilla.org/mozilla-central/source/dom/indexedDB/ActorsChild.cpp?rev=c0ce357af3db#2030
Looks like the code was added in bug 994190 relatively recently.
Fixed by bug 1081703.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1081703
You need to log in before you can comment on or make changes to this bug.