Closed Bug 1094945 Opened 7 years ago Closed 6 years ago

crash in js::random_initState

Categories

(Core :: JavaScript Engine, defect)

36 Branch
All
Windows NT
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1167248
Tracking Status
firefox36 --- affected

People

(Reporter: jbecerra, Unassigned)

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-4f597a56-c317-4322-8912-f76662141023.
=============================================================

The signature has been around for some time, but it is showing up on the list of top 50 crashers for nightly Fx36. It's a startup crash. Most of the reports are dupes. There are no comments in the reports. All of these are happening in Windows 7.

More reports at: https://crash-stats.mozilla.com/report/list?product=Firefox&signature=invalid_parameter_noinfo

0 	xul.dll 	google_breakpad::ExceptionHandler::HandleInvalidParameter(wchar_t const*, wchar_t const*, wchar_t const*, unsigned int, unsigned __int64) 	toolkit/crashreporter/google-breakpad/src/client/windows/handler/exception_handler.cc
1 	msvcr120.dll 	invalid_parameter_noinfo 	f:\dd\vctools\crt\crtw32\misc\invarg.c:96
2 	msvcr120.dll 	rand_s 	f:\dd\vctools\crt\crtw32\misc\rand_s.c:62
3 	mozjs.dll 	js::random_initState(unsigned __int64*) 	js/src/jsmath.cpp
4 	mozjs.dll 	js::random_nextDouble(unsigned __int64*) 	js/src/jsmath.h
5 	mozjs.dll 	js::math_random(JSContext*, unsigned int, JS::Value*) 	js/src/jsmath.cpp
6 	mozjs.dll 	js::Invoke(JSContext*, JS::CallArgs, js::MaybeConstruct) 	js/src/vm/Interpreter.cpp
7 	mozjs.dll 	Interpret 	js/src/vm/Interpreter.cpp
8 	mozjs.dll 	js::RunScript(JSContext*, js::RunState&) 	js/src/vm/Interpreter.cpp
9 	mozjs.dll 	js::ExecuteKernel(JSContext*, JS::Handle<JSScript*>, JSObject&, JS::Value const&, js::ExecuteType, js::AbstractFramePtr, JS::Value*) 	js/src/vm/Interpreter.cpp
10 	mozjs.dll 	js::Execute(JSContext*, JS::Handle<JSScript*>, JSObject&, JS::Value*) 	js/src/vm/Interpreter.cpp
11 	mozjs.dll 	ExecuteScript 	js/src/jsapi.cpp
12 	mozjs.dll 	JS_ExecuteScriptVersion(JSContext*, JS::Handle<JSObject*>, JS::Handle<JSScript*>, JS::MutableHandle<JS::Value>, JSVersion) 	js/src/jsapi.cpp
13 	xul.dll 	mozJSSubScriptLoader::DoLoadSubScriptWithOptions(nsAString_internal const&, LoadSubScriptOptions&, JSContext*, JS::MutableHandle<JS::Value>) 	js/xpconnect/loader/mozJSSubScriptLoader.cpp
14 	xul.dll 	mozJSSubScriptLoader::LoadSubScript(nsAString_internal const&, JS::Handle<JS::Value>, nsAString_internal const&, JSContext*, JS::MutableHandle<JS::Value>) 	js/xpconnect/loader/mozJSSubScriptLoader.cpp
15 	xul.dll 	XPTC__InvokebyIndex 	xpcom/reflect/xptcall/md/win32/xptcinvoke_asm_x86_64.asm
16 	xul.dll 	xul.dll@0x1cfd203 	
17 	xul.dll 	XPCWrappedNative::CallMethod(XPCCallContext&, XPCWrappedNative::CallMode) 	js/xpconnect/src/XPCWrappedNative.cpp
18 	xul.dll 	XPC_WN_CallMethod(JSContext*, unsigned int, JS::Value*) 	js/xpconnect/src/XPCWrappedNativeJSOps.cpp
19 	mozjs.dll 	js::Invoke(JSContext*, JS::CallArgs, js::MaybeConstruct) 	js/src/vm/Interpreter.cpp
20 	mozjs.dll 	Interpret 	js/src/vm/Interpreter.cpp
21 	mozjs.dll 	js::RunScript(JSContext*, js::RunState&) 	js/src/vm/Interpreter.cpp
22 	mozjs.dll 	js::ExecuteKernel(JSContext*, JS::Handle<JSScript*>, JSObject&, JS::Value const&, js::ExecuteType, js::AbstractFramePtr, JS::Value*) 	js/src/vm/Interpreter.cpp
23 	mozjs.dll 	js::Execute(JSContext*, JS::Handle<JSScript*>, JSObject&, JS::Value*) 	js/src/vm/Interpreter.cpp
24 	mozjs.dll 	ExecuteScript 	js/src/jsapi.cpp
25 	mozjs.dll 	JS_ExecuteScriptVersion(JSContext*, JS::Handle<JSObject*>, JS::Handle<JSScript*>, JSVersion) 	js/src/jsapi.cpp
26 	xul.dll 	mozJSComponentLoader::ObjectForLocation(ComponentLoaderInfo&, nsIFile*, JS::MutableHandle<JSObject*>, JS::MutableHandle<JSScript*>, char**, bool, JS::MutableHandle<JS::Value>) 	js/xpconnect/loader/mozJSComponentLoader.cpp
27 	xul.dll 	mozJSComponentLoader::ImportInto(nsACString_internal const&, JS::Handle<JSObject*>, JSContext*, JS::MutableHandle<JSObject*>) 	js/xpconnect/loader/mozJSComponentLoader.cpp
28 	xul.dll 	mozJSComponentLoader::Import(nsACString_internal const&, JS::Handle<JS::Value>, JSContext*, unsigned char, JS::MutableHandle<JS::Value>) 	js/xpconnect/loader/mozJSComponentLoader.cpp
29 	xul.dll 	nsXPCComponents_Utils::Import(nsACString_internal const&, JS::Handle<JS::Value>, JSContext*, unsigned char, JS::MutableHandle<JS::Value>) 	js/xpconnect/src/XPCComponents.cpp
30 	xul.dll 	XPTC__InvokebyIndex 	xpcom/reflect/xptcall/md/win32/xptcinvoke_asm_x86_64.asm
31 		@0x31628ff 	
32 	xul.dll 	XPCWrappedNative::CallMethod(XPCCallContext&, XPCWrappedNative::CallMode) 	js/xpconnect/src/XPCWrappedNative.cpp
33 	xul.dll 	XPC_WN_CallMethod(JSContext*, unsigned int, JS::Value*) 	js/xpconnect/src/XPCWrappedNativeJSOps.cpp
34 	mozjs.dll 	js::Invoke(JSContext*, JS::CallArgs, js::MaybeConstruct) 	js/src/vm/Interpreter.cpp
35 	mozjs.dll 	Interpret 	js/src/vm/Interpreter.cpp
36 	mozjs.dll 	js::RunScript(JSContext*, js::RunState&) 	js/src/vm/Interpreter.cpp
37 	mozjs.dll 	js::ExecuteKernel(JSContext*, JS::Handle<JSScript*>, JSObject&, JS::Value const&, js::ExecuteType, js::AbstractFramePtr, JS::Value*) 	js/src/vm/Interpreter.cpp
38 	mozjs.dll 	js::Execute(JSContext*, JS::Handle<JSScript*>, JSObject&, JS::Value*) 	js/src/vm/Interpreter.cpp
39 	mozjs.dll 	ExecuteScript 	js/src/jsapi.cpp
40 	mozjs.dll 	JS_ExecuteScriptVersion(JSContext*, JS::Handle<JSObject*>, JS::Handle<JSScript*>, JSVersion) 	js/src/jsapi.cpp
41 	xul.dll 	mozJSComponentLoader::ObjectForLocation(ComponentLoaderInfo&, nsIFile*, JS::MutableHandle<JSObject*>, JS::MutableHandle<JSScript*>, char**, bool, JS::MutableHandle<JS::Value>) 	js/xpconnect/loader/mozJSComponentLoader.cpp
42 	xul.dll 	mozJSComponentLoader::ImportInto(nsACString_internal const&, JS::Handle<JSObject*>, JSContext*, JS::MutableHandle<JSObject*>) 	js/xpconnect/loader/mozJSComponentLoader.cpp
43 	xul.dll 	mozJSComponentLoader::Import(nsACString_internal const&, JS::Handle<JS::Value>, JSContext*, unsigned char, JS::MutableHandle<JS::Value>) 	js/xpconnect/loader/mozJSComponentLoader.cpp
44 	xul.dll 	nsXPCComponents_Utils::Import(nsACString_internal const&, JS::Handle<JS::Value>, JSContext*, unsigned char, JS::MutableHandle<JS::Value>) 	js/xpconnect/src/XPCComponents.cpp
45 	xul.dll 	XPTC__InvokebyIndex 	xpcom/reflect/xptcall/md/win32/xptcinvoke_asm_x86_64.asm
46 		@0x31628e7 	
47 	xul.dll 	XPCWrappedNative::CallMethod(XPCCallContext&, XPCWrappedNative::CallMode) 	js/xpconnect/src/XPCWrappedNative.cpp
48 	xul.dll 	XPC_WN_CallMethod(JSContext*, unsigned int, JS::Value*) 	js/xpconnect/src/XPCWrappedNativeJSOps.cpp
49 	mozjs.dll 	js::Invoke(JSContext*, JS::CallArgs, js::MaybeConstruct) 	js/src/vm/Interpreter.cpp
50 	mozjs.dll 	Interpret 	js/src/vm/Interpreter.cpp
51 	mozjs.dll 	js::RunScript(JSContext*, js::RunState&) 	js/src/vm/Interpreter.cpp
52 	mozjs.dll 	js::ExecuteKernel(JSContext*, JS::Handle<JSScript*>, JSObject&, JS::Value const&, js::ExecuteType, js::AbstractFramePtr, JS::Value*) 	js/src/vm/Interpreter.cpp
53 	mozjs.dll 	js::Execute(JSContext*, JS::Handle<JSScript*>, JSObject&, JS::Value*) 	js/src/vm/Interpreter.cpp
54 	mozjs.dll 	ExecuteScript 	js/src/jsapi.cpp
55 	mozjs.dll 	JS_ExecuteScriptVersion(JSContext*, JS::Handle<JSObject*>, JS::Handle<JSScript*>, JSVersion) 	js/src/jsapi.cpp
56 	xul.dll 	mozJSComponentLoader::ObjectForLocation(ComponentLoaderInfo&, nsIFile*, JS::MutableHandle<JSObject*>, JS::MutableHandle<JSScript*>, char**, bool, JS::MutableHandle<JS::Value>) 	js/xpconnect/loader/mozJSComponentLoader.cpp
57 	xul.dll 	mozJSComponentLoader::LoadModule(mozilla::FileLocation&) 	js/xpconnect/loader/mozJSComponentLoader.cpp
58 	xul.dll 	nsComponentManagerImpl::KnownModule::Load() 	xpcom/components/nsComponentManager.cpp
59 	xul.dll 	nsFactoryEntry::GetFactory() 	xpcom/components/nsComponentManager.cpp
60 	xul.dll 	nsComponentManagerImpl::CreateInstanceByContractID(char const*, nsISupports*, nsID const&, void**) 	xpcom/components/nsComponentManager.cpp
61 	xul.dll 	nsComponentManagerImpl::GetServiceByContractID(char const*, nsID const&, void**) 	xpcom/components/nsComponentManager.cpp
62 	xul.dll 	nsGetServiceByContractIDWithError::operator()(nsID const&, void**) 	xpcom/glue/nsComponentManagerUtils.cpp
63 	xul.dll 	nsCOMPtr_base::assign_from_gs_contractid_with_error(nsGetServiceByContractIDWithError const&, nsID const&) 	xpcom/glue/nsCOMPtr.cpp
64 	xul.dll 	nsAppStartupNotifier::Observe(nsISupports*, char const*, wchar_t const*) 	embedding/components/appstartup/nsAppStartupNotifier.cpp
65 	xul.dll 	XREMain::XRE_mainRun() 	toolkit/xre/nsAppRunner.cpp
66 	xul.dll 	XREMain::XRE_main(int, char** const, nsXREAppData const*) 	toolkit/xre/nsAppRunner.cpp
67 	xul.dll 	XRE_main 	toolkit/xre/nsAppRunner.cpp
68 	firefox.exe 	do_main 	browser/app/nsBrowserApp.cpp
69 	firefox.exe 	NS_internal_main(int, char**) 	browser/app/nsBrowserApp.cpp
70 	firefox.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp
71 	firefox.exe 	__tmainCRTStartup 	f:/dd/vctools/crt/crtw32/startup/crt0.c:255
72 	kernel32.dll 	BaseThreadInitThunk 	
73 	ntdll.dll 	RtlUserThreadStart
HandleInvalidParameter and invalid_parameter_noinfo should be on the skiplist because they are just symptoms of a problem further down on the stack (I'll file a Socorro bug).

This particular stack with js::random is just a one-off in that bucket. Most of the invalid_parameter reports are from a single installation hitting a stack unrelated to this one.

I don't think we need to worry about this unless the volume continues and grows even larger.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1167248
You need to log in before you can comment on or make changes to this bug.