Browser toolbox's default panel shouldn't be debugger

RESOLVED DUPLICATE of bug 1031404

Status

()

Firefox
Developer Tools: Framework
RESOLVED DUPLICATE of bug 1031404
3 years ago
3 years ago

People

(Reporter: fitzgen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Because it puts the whole browser in debug mode and then if you try and profile, your results will be skewed. This is especially bad because we don't have a way to disable the debugger in the UI.

Maybe console should be default? Inspector?
A different approach to slow startup from debugger is discussed in bug 1031404 (open on the last used tool).

Picking a different default would also be okay with me, as long as the "--jsdebugger" CLI option still starts on the debugger panel.
See Also: → bug 1031404
Component: Developer Tools → Developer Tools: Framework
This seems like a dup of 1031404, which aims to just open on the last used panel in the browser toolbox
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1031404
You need to log in before you can comment on or make changes to this bug.