GET request for YouTube noflv video is a 404

VERIFIED WORKSFORME

Status

www.mozilla.org
Pages & Content
--
major
VERIFIED WORKSFORME
3 years ago
3 years ago

People

(Reporter: stephend, Unassigned)

Tracking

Development/Staging

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8518295 [details]
404-video.png

STR:

1. Load https://www-demo3.allizom.org/en-US/ (nightly, Windows 7)
2. Open the Web Console in Firefox
3. Click Play Video
4. Look at the requests in the Web Console

Actual Results:

There's a 404 on a GET request to a non-FLV video:

https://www.youtube.com/get_video?noflv=1&video_id=r0-djEaGW2A&cpn=Bhj-VZgKepPOF2Cw&el=embedded&referrer&eurl=https%3A%2F%2Fwww-demo3.allizom.org%2Fen-US%2F&fmt=18&ptk=youtube_none&splay=1
Hi Jon or Craig-

Can you reproduce this one on prod?

Thx,
Jen
Group: mozilla-employee-confidential
Doesn't seem to be happening on prod. Maybe it got fixed along the way?

Comment 3

3 years ago
I can't reproduce on production or on demo3, whether using OS X or Nightly on my Windows 7 VM.

We did see this a bit during development and chalked it up to the YouTube API being weird. It looks like there's a bug filed for a similar (if not matching) issue: https://code.google.com/p/gdata-issues/issues/detail?id=6267

However, I can't reproduce using the steps listed in that bug, either.

As far as I've seen, when this 404 does occur, it doesn't affect playback or any other functionality on the page.
Thanks!  Closing!
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

3 years ago
Verified WFM too.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

3 years ago
Created attachment 8521816 [details]
youtube-verified.png
You need to log in before you can comment on or make changes to this bug.