Copy context menu stops working in Page Info

VERIFIED FIXED in Firefox 36

Status

()

Firefox
Page Info Window
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Alice0775 White, Assigned: efaust)

Tracking

({regression})

36 Branch
Firefox 36
regression
Points:
---

Firefox Tracking Flags

(firefox35 unaffected, firefox36+ verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
[Tracking Requested - why for this release]: regression

Steps To Reproduce:
1. Open any page which contains images
   (e.g. https://bugzilla.mozilla.org/ )
2. Open Page Info and select Media tab
3. Attempt to copy an image url with right click context menu

Actual Results:
No thing copied.

The following error mesage is shown in Error Console:

Error: ReferenceError: gClipboardHelper is not defined
Source File: chrome://browser/content/pageinfo/pageInfo.js
Line: 1211


Expected Results:
Copy command should be performed succesfully without error.

Regression window(m-i)
Good:
https://hg.mozilla.org/integration/mozilla-inbound/rev/3dc4a906df95
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0 ID:20141104134948
Bad:
https://hg.mozilla.org/integration/mozilla-inbound/rev/a9a7f16c817b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0 ID:20141104140142
Pushlog;
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=3dc4a906df95&tochange=a9a7f16c817b

Regressed by: Bug 611388
(Reporter)

Updated

3 years ago
Flags: needinfo?(efaustbmo)
(Assignee)

Comment 1

3 years ago
Created attachment 8518360 [details] [diff] [review]
fixpageinfo.patch

Yeah, that's me. I took a look around for these, but apparently missed at least one.
Assignee: nobody → efaustbmo
Status: NEW → ASSIGNED
Flags: needinfo?(efaustbmo)
Attachment #8518360 - Flags: review?(dao)
Comment on attachment 8518360 [details] [diff] [review]
fixpageinfo.patch

Review of attachment 8518360 [details] [diff] [review]:
-----------------------------------------------------------------

A test to make sure this doesn't happen again would be good.
Attachment #8518360 - Flags: review?(dao) → review+
https://hg.mozilla.org/mozilla-central/rev/763ae102275b
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 36
status-firefox36: affected → fixed
tracking-firefox36: ? → +

Comment 5

3 years ago
 Bugday-20141218 :Able to perform copy command successfully without error.
Status: RESOLVED → VERIFIED
status-firefox36: fixed → verified

Updated

3 years ago
See Also: → bug 1147456
You need to log in before you can comment on or make changes to this bug.