[EverythingMe] NOT able to access "Twitter"

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
4 years ago
10 months ago

People

(Reporter: fmuyumba, Unassigned, NeedInfo)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 unaffected)

Details

(Whiteboard: [2.1-exploratory-3], URL)

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8518425 [details]
logcat_20141106_1247.txt

Description:
The User is NOT able to access "Twitter" from "EverythingMe - Privacy"

Repro Steps:
1) Update a Flame device to BuildID: 20141106001204
2) Launch "Settings"> Tap on "Device information"
3) Tap on "Your privacy"
4) Tap on "EverythingMe"
5) Tap on "Contact"
6) Scroll down and under "Follow Us", tap on "Twitter"
7) Observe the error message
  
Actual:
"Unable to connect" error message appears
  
Expected: 
User is able to access "Twitter"
  
Environmental Variables:
Device: Flame 2.1 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141106001204
Gaia: 9658b93b412bdcc0f953d668e8c8e68318c99fb8
Gecko: 76880403db44
Version: 34.0 
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
  
  
Repro frequency: 100%
See attached: video & logcat: http://youtu.be/xL2AQwSscQ0
Flags: needinfo?(dharris)
(Reporter)

Comment 1

4 years ago
This issue is NOT reproducible on Flame 2.2 Master (319mb)(Kitkat Base)(Shallow Flash) and Flame 2.0 (319mb)(Kitkat Base)(Shallow Flash)

Result: The User IS able to access "Twitter" from "EverythingMe - Privacy"

Environmental Variables:
Device: Flame 2.2 Master (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141105160209
Gaia: 7918024c737c4570cacd784f267e28737ae05dea
Gecko: 2114ef80f6ae
Version: 36.0a1 
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

----------------------------------------------------------------------------------------------------

Environmental Variables:
Device: Flame 2.0 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141105183012
Gaia: 5ee26701a4d8db266bfb203b2179f686ce14d8b6
Gecko: dbf49343e889
Version: 32.0 
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
The Everything.me twitter link is https://twitter.com/everythingme
but in their Web page it is https://twitter.com/#!/everythingme Old URL style.

Somehow it seems that Firefox OS has a trouble with this URI.
Maybe JavaScript is deactivated in some contexts. This is not an evangelization bug, except for the part that everything.me would be better to switch to the new style of URI of twitter (The old one was a bad idea and it shows why with this bug.)
Putting someone from everything.me in needinfo
Changing to Firefox OS::Gaia


For the reporter, please use the URI field for where the issue actually occurs. Thanks. :)
Replacing http://youtu.be/xL2AQwSscQ0
with      http://everything.me/contact/
Component: Mobile → Gaia
Flags: needinfo?(efrat)
Product: Tech Evangelism → Firefox OS
(Reporter)

Comment 3

4 years ago
Created attachment 8520796 [details]
Updated Video

Updated Video
(Reporter)

Comment 4

4 years ago
Updated Video: http://youtu.be/7TqpQ3se0Os
This could be very confusing to the user, as an error message is occuring, because the user is not redirected to the mobile site correctly. NI Browser/Rocketbar owner for a blocking desicion
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris) → needinfo?(mozillamarcia.knous)
Summary: [Tech Evangelism][EverythingMe] NOT able to access "Twitter" → [EverythingMe] NOT able to access "Twitter"
This shouldn't block although it would be nice if it could be fixed. Let's wait for e.me to comment.
Flags: needinfo?(mozillamarcia.knous)

Comment 7

10 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.