If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Standardize on cb() vs callback()

RESOLVED FIXED

Status

Hello (Loop)
Server
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: pdehaan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Steps to reproduce:

$ egrep -nir "callback\(" . --exclude-dir={coverage,node_modules} | wc -l
     147

$ egrep -nir "cb\(" . --exclude-dir={coverage,node_modules} | wc -l
      62


Actual results:
callback(): 147 instances
cb():        62 instances


Expected results:
consistent use of `cb()` or `callback()` throughout code.
Yes, thanks. Preferred way is to use `callback` everywhere.
Created attachment 8525959 [details] [review]
Link to GitHub PR.

I just continue to use cb for async.map callbacks in redis backend since we already use callback for the method callbacks.
Attachment #8525959 - Flags: review?(tarek)
Attachment #8525959 - Flags: feedback?(pdehaan)
see: egrep -nir "cb\(" . --exclude-dir={coverage,node_modules,loadtests}

Updated

3 years ago
Attachment #8525959 - Flags: review?(tarek) → review+
https://github.com/mozilla-services/loop-server/commit/54d9c07f27c22af7bc9d1fbe202667e5b1a7e865
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Attachment #8525959 - Flags: feedback?(pdehaan)
You need to log in before you can comment on or make changes to this bug.