mozilla hangs frequently when used with HTTP proxy

VERIFIED WORKSFORME

Status

()

Core
Networking: HTTP
--
blocker
VERIFIED WORKSFORME
17 years ago
16 years ago

People

(Reporter: JKras, Assigned: Darin Fisher)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Mozilla build ID: 2001110903
HTTP Proxy Server: Squid/2.4.STABLE2

I noticed that the last few Mozilla builds (last week or so) have problems with
the proxy connections. It works fine for a while via an HTTP proxy and then it
stops responding, I click on a link and nothing happens anymore. I have to shut
down Mozilla and restart it and then it works again. At the same time the proxy
server is OK and so are the sites as I can access them just fine from IE.

Note that things were fine until last week or so. There were no upgrades in the
version of the proxy server I am using, the only thing upgraded was my version
of Mozilla.

I have Mozilla configured to use HTTP/1.1, Enable Keepalive, Enable pipelining.
I also tried setting HTTP/1.0 and disabling keepalives and pipelining but it
does not seem to make a difference.

I tried looking for simillar bugs but I could not find one quite like this.

Comment 1

17 years ago
Two people in Japan reported they can't see authentification dialog
via http proxy(Squid, WinGate, Delegate).

http://bugzilla.mozilla.gr.jp/show_bug.cgi?id=1482
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
http
Assignee: neeti → av
Component: Networking → Plug-ins
QA Contact: benc → shrir

Comment 3

17 years ago
http
Assignee: av → darin
Component: Plug-ins → Networking: HTTP
QA Contact: shrir → tever
(Assignee)

Comment 4

17 years ago
reporter: can you reproduce this problem using a more recent nightly build?
(Reporter)

Comment 5

17 years ago
Seems to be OK now with the 11/20 build, Mozilla 0.9.6

I guess you can close this bug if other users don't have the same problem.
Thanks for your answer !

marking worksforme
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 7

16 years ago
verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.