Animations don't run if we set a class on document.body before

RESOLVED DUPLICATE of bug 927349

Status

Firefox OS
Gaia
RESOLVED DUPLICATE of bug 927349
4 years ago
3 years ago

People

(Reporter: mancas, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
When we set a class to the document.body, per example, to prevent pointer events, before a dialog is displayed,the animation that should perform the system immediately, doesn't run properly.

See [1] for more information


[1] https://bugzilla.mozilla.org/show_bug.cgi?id=1091299#c10
Hey Chris, I think this bug is now obsoleted by the project Silk patches. What do you think?
Flags: needinfo?(chrislord.net)

Comment 2

3 years ago
(In reply to Julien Wajsberg [:julienw] from comment #1)
> Hey Chris, I think this bug is now obsoleted by the project Silk patches.
> What do you think?

I'm not entirely certain what this bug is about, but I don't see why/how project Silk would affect it - Project Silk just gives us more consistent composite times and pointer events, but it doesn't really change anything significant in layout/style (as far as I'm aware).
Flags: needinfo?(chrislord.net)
OK, maybe "Project Silk" was not the right name :)

I think a bug landed recently where we now wait for restyles/reflows before starting transitions. I think this bug is fixed with it. I kind of thought you would know what I'm talking about :)

Comment 4

3 years ago
(In reply to Julien Wajsberg [:julienw] from comment #3)
> OK, maybe "Project Silk" was not the right name :)
> 
> I think a bug landed recently where we now wait for restyles/reflows before
> starting transitions. I think this bug is fixed with it. I kind of thought
> you would know what I'm talking about :)

Oh sorry, yes, I see :) That'll be bug 927349 - if this bug was just that the animation was skipped due to the work of the restyle, then this may well be fixed. I still don't really understand comment #0, so I suppose this needs to be verified by someone that knows the described problem.
Yeah, I thought of that one :) thanks a lot, I'm duping.

I was the one asking Manuel to file this bug so I'm confident this is it :)

Thanks !
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 927349
You need to log in before you can comment on or make changes to this bug.