Mozilla wont play embedded midi files

VERIFIED WONTFIX

Status

()

VERIFIED WONTFIX
17 years ago
17 years ago

People

(Reporter: bespo, Assigned: serhunt)

Tracking

Trunk
x86
OS/2
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:0.9.5+) Gecko/20011107
BuildID:    2001110711

NPOS2AUD.DLL
NPOS2MID.DLL
NPOS2VID.DLL

Mozilla just exits and produces the trap I pasted in "additional Info" below,
when trying to listen to a .wav, .mid or look at an .avi or .mpg


Reproducible: Always
Steps to Reproduce:
1.go to http://cereal.mv.com/reef   there is an embeded midi there
2.
3.

Actual Results:  Mozilla will exit

Expected Results:  should play sound

by the way, Flash 4 and Acrobat3 work, but that's all the plugins I can get to work.

11-10-2001  09:15:32  SYS3175  PID 0863  TID 0001  Slot 017a
F:\WARPZILLA0952\MOZILLA.EXE
c0000005
1f203bee
P1=00000001  P2=00000000  P3=XXXXXXXX  P4=XXXXXXXX  
EAX=00000000  EBX=016eb710  ECX=016e007c  EDX=016eb710
ESI=00000000  EDI=00000000  
DS=0053  DSACC=d0f3  DSLIM=3fffffff  
ES=0053  ESACC=d0f3  ESLIM=3fffffff  
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:1f203bee  CSACC=d0df  CSLIM=3fffffff
SS:ESP=0053:0012e468  SSACC=d0f3  SSLIM=3fffffff
EBP=0012e470  FLG=00012246

SW.DLL 0001:00013bee
(Reporter)

Comment 1

17 years ago
Ok, my bad.  For some reason I couldnt get Mozilla to play wav's and midi's
before, hence I tried the NS 4.61 plugins.

Removing the plugins, Mozilla does indeed play wav and mid files. 

HOWEVER, it doesn't play the embedded midi on the referenced web page
http://cereal.mv.com/reef

Also, Mozilla does indeed crash still when trying to play an avi file.  I will
open up another bug report.

Sorry for the bad info.   But there is still an audio bug with regard to the
embedded midi
Severity: critical → normal
Summary: Crash when using NS4.61 OS/2 audio and video plug-ins → Mozilla wont play embedded midi files

Comment 2

17 years ago
This is a bug in the multimedia plugin.

The 4.61 Multimedia plugins are not supported on Warpzilla because the have a 
poorly designed architecture that depends on 4.61.

so embedded MIDIs and WAVs won't work until someone writes new multimedia 
plugins.

When you click a MIDI or WAV, we just send it to the WPS.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX

Comment 3

17 years ago
v
Status: RESOLVED → VERIFIED
*** Bug 142837 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.