Remove getBookmarksForURI and getMostRecentBookmarkForURI from PlacesUtils

RESOLVED FIXED in Firefox 60

Status

()

defect
P1
normal
RESOLVED FIXED
5 years ago
a year ago

People

(Reporter: mak, Assigned: mak)

Tracking

(Blocks 3 bugs, {perf})

Trunk
mozilla60
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify -

Firefox Tracking Flags

(firefox60 fixed)

Details

(Whiteboard: [reserve-photon-performance] [qf-][fxsearch])

Attachments

(1 attachment)

Assignee

Description

5 years ago
We must deprecate this pseudo-api and make its consumers use Bookmarks.jsm API.

Unfortunately here we are going sync->async so consumers won't be ready.
Flags: qe-verify-
Flags: firefox-backlog+
Assignee

Updated

4 years ago
Assignee

Updated

4 years ago
Depends on: 951651
No longer depends on: PlacesAsyncTransact
Assignee

Updated

4 years ago
Assignee

Updated

4 years ago
No longer blocks: 1141547
Assignee

Updated

4 years ago
Priority: -- → P1
Assignee

Updated

4 years ago
Keywords: perf
Whiteboard: [qf]
Points: 5 → ---
Flags: firefox-backlog+
Priority: P1 → P2
Whiteboard: [qf] → [photon-performance] [qf]
Whiteboard: [photon-performance] [qf] → [photon-performance] [qf-]
Priority: P2 → P3
Whiteboard: [photon-performance] [qf-] → [reserve-photon-performance] [qf-]
Assignee

Updated

2 years ago
Summary: Deprecate PlacesUtils.getBookmarksForURI → Remove PlacesUtils.getBookmarksForURI
Assignee

Updated

2 years ago
Depends on: 1383027
Priority: P3 → P4
Assignee

Updated

2 years ago
Depends on: 1131491
Assignee

Updated

2 years ago
No longer depends on: PlacesAsyncTransact
Assignee

Updated

2 years ago
Blocks: 1083465
Assignee

Updated

a year ago
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Priority: P4 → P1
Summary: Remove PlacesUtils.getBookmarksForURI → Remove getBookmarksForURI and getMostRecentBookmarkForURI from PlacesUtils
Assignee

Updated

a year ago
Duplicate of this bug: 1095408

Comment 3

a year ago
mozreview-review
Comment on attachment 8944668 [details]
Bug 1095406 - Remove synchronous getBookmarksForURI and getMostRecentBookmarkForURI from PlacesUtils.

https://reviewboard.mozilla.org/r/214828/#review220496
Attachment #8944668 - Flags: review?(standard8) → review+
Assignee

Updated

a year ago
Blocks: 1432439

Comment 4

a year ago
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/5095d9a704a4
Remove synchronous getBookmarksForURI and getMostRecentBookmarkForURI from PlacesUtils. r=standard8

Comment 5

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/5095d9a704a4
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
Assignee

Updated

a year ago
Whiteboard: [reserve-photon-performance] [qf-] → [reserve-photon-performance] [qf-][fxsearch]
You need to log in before you can comment on or make changes to this bug.