Closed Bug 1095455 Opened 5 years ago Closed 5 years ago

startup crash in XPCWrappedNativeScope::XPCWrappedNativeScope(JSContext*, JS::Handle<JSObject*>)

Categories

(Core :: XPConnect, defect, critical)

defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1095305

People

(Reporter: djc, Unassigned)

Details

(Keywords: crash, regression)

This bug was filed from the Socorro interface and is 
report bp-b078aa37-54e9-4e60-93d6-04b272141107.
=============================================================
On updating to today's nightlies, I crashed about a zillion times restarting. This might be due to one of the addons I have installed, since it seems to work in safe mode.
Looks like the crash is in addon interposition code.
If I try to enable "meta-q-override" (0.6), it also crashes (all other addons disabled).
On the other hand, enabling "No Close Buttons" (0.1), a very simple SDK-based addon I made, seems to work.
And, disabling e10s, then starting to enable my addons one by one, also crashed in the same way. However, this only seemed to happen for the meta-q-override one. Which now seems to work correctly in a fresh, non-e10s session.
Same startup crash here. Had to revert to previous Nightly and disable updates.
Same issue while running Firebug.next (https://github.com/firebug/firebug.next ) using |jpm run| or |jpm test| and the latest Nightly.

Florent.
> Platform: 	All Mac OS X 

I am using Linux.

Florent
tracking-e10s: --- → ?
[Tracking Requested - why for this release]:
This has a pretty large list of crashes given that it's new with today's Nightly only.

It happens on all platforms, on Linux and and Mac it looks like a null deref (0x0 address) but on Windows it's a EXCEPTION_BREAKPOINT with a high address.

See more of those crashes on https://crash-stats.mozilla.com/report/list?product=Firefox&signature=XPCWrappedNativeScope%3A%3AXPCWrappedNativeScope%28JSContext*%2C+JS%3A%3AHandle%3CJSObject*%3E%29&product=Firefox&version=Firefox%3A36.0a1#tab-reports
Summary: crash in XPCWrappedNativeScope::XPCWrappedNativeScope(JSContext*, JS::Handle<JSObject*>) → startup crash in XPCWrappedNativeScope::XPCWrappedNativeScope(JSContext*, JS::Handle<JSObject*>)
This crash started today because of e10s being forced on in Nightly.  The crash happens after disabling e10s and restarting the browser.

I do have many addon-ons, but only since e10s got enabled has something become screwed up.
Blocks: 1093691
Keywords: regression
OS: Mac OS X → All
(In reply to IU from comment #9)
> This crash started today because of e10s being forced on in Nightly.  The
> crash happens after disabling e10s and restarting the browser.

Disabling e10s did not help on my machine. I'm not sure whether that is really caused by flipping it on.
(In reply to Tim Taubert [:ttaubert] from comment #10)
> Disabling e10s did not help on my machine. I'm not sure whether that is
> really caused by flipping it on.

My statement is that disabling it causes the crash for me (_NOT_ the it resolves it).
Oh, hm. Nightly crashed for me with e10s on and off.
starting Nightly with a new profile and installing the Ghostery add-on instantly crashes the browser, same if I disable e10s beforehand. And of course it crashes at startup if Ghostery is already installed.
Hmm.  I guess the e10s connection is merely coincidental.  I've found disabling e10s and going back to yesterday's nightly stops the crashing for me.  So something else caused the regression.
No longer blocks: 1093691
This is a regression from bug 1092156, which has now been backed out. I'm going to dupe this to bug 1095305 since that one has a little more information.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1095305
This crash started happening to me after e10s was disabled due to me using accessibility. Before that, the first launch after update, had worked. But since accessibility code isn't fully e10s ready yet, I opted into disabling e10s.

bp-1341e01c-5ec6-4b89-b862-126032141107
bp-e08ee57c-29df-4f29-a890-6a4932141107
My story to reproduce:
enable 1password Extension
restart firefox
->crash
https://crash-stats.mozilla.com/report/index/fae24be4-ddfc-4d86-a5eb-9cd8c2141107
https://crash-stats.mozilla.com/report/index/64453057-e338-4f15-abdd-7f2942141107
(and others)

Reproducible On Build ID Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:36.0) Gecko/20100101 Firefox/36.0 ID:20141107030202 CSet: 17e190839086
Duplicate of this bug: 1095562
Just to have it referenced here as well: After bug 1092156 was backed out, new Nightly builds have been triggered. Once those are available, you should be able to update to those and have things working again. Sorry!
Crash Signature: [@ XPCWrappedNativeScope::XPCWrappedNativeScope(JSContext*, JS::Handle<JSObject*>)]
tracking-e10s: ? → ---
You need to log in before you can comment on or make changes to this bug.