“Back” link is not displayed when trying to reset password in Consumer Pages

VERIFIED FIXED

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: madalin.cotetiu, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8518889 [details]
Reset_pass_consumer_pg.png

Steps to reproduce:
1. Load MP Consumer Pages and click “Sign In” button and then click “Forgot password?” link (https://marketplace-dev.allizom.org/) 

Expected results:
In “Reset password” popup windows, under the “Next” button, a “Back” link is displayed.

Actual results:
The "Back" link is not displayed when you try to reset password in Consumer Pages.

Notes/Issues:
When resetting the password from Dev Hub the "Back" link is displayed.
Verified on FF36 (Win 7). Issue is reproducing in MP-dev and MP-stage.
Attaching screenshot for this issue.

Updated

4 years ago
Component: Consumer Pages → Server: Firefox Accounts
Product: Marketplace → Mozilla Services
Target Milestone: 2014-11-11 → ---
Version: Avenir → other
I am unable to reproduce using the above STRs - does the user need to be signed in to Marketplace or use some alternate path to access FxA? Does the user's Marketplace session have to be expired?
Under what conditions will FxA's /signin page be opened with an email address? In those situations, are you trying to force a user to re-authenticate as a specified user? If so, could you call `/force_auth?email=<email>` instead?
Flags: needinfo?(amckay)
I believe you can trigger this with a basic login attempt from production Marketplace.

1) Go to marketplace.firefox.com
2) Click Sign in
3) Enter any email address
4) This will take you to the FxA Signup page. Navigate to FxA Sign in page.
5) Click forgot password.

No Back link.
Flags: needinfo?(amckay)
Fixed and released in prod: https://github.com/mozilla/fxa-content-server/pull/1927
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

4 years ago
Verified as fixed in FF37(Win7) in marketplace-dev.allizom.org
postfix screenshot: http://screencast.com/t/R4v5MgsVx
Closing.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.