After a conference call made with the non-default SIM, the SIM picker displays this SIM instead of the default one

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Dialer
RESOLVED WONTFIX
4 years ago
3 months ago

People

(Reporter: jlorenzo, Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Reporter)

Description

4 years ago
Prerequisites
Have SIM1 set as the default SIM for outgoing calls.

STR
1. Call the voicemail with SIM2.
2. Add another call with SIM2 by using one MSAB button in dialer.
3. Merge these calls.
4. Hang up.

Actual result
The MSAB button used in step 2 still displays SIM2 instead of SIM1. The issue is minor tough because when you tap it, SIM1 appears and you make a call with SIM1.
(Reporter)

Comment 1

4 years ago
Note: The issue doesn't occur if you don't set up a conference call.
status-b2g-v2.2: --- → affected
(Reporter)

Comment 2

4 years ago
Reproduced on 2.1:
Gaia-Rev        6295f6acfe91c6ae659712747dd2b9c8f51d0339
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/8c23b4f2ba29
Build-ID        20141107001205
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  39
FW-Date         Thu Oct 16 18:19:14 CST 2014
Bootloader      L1TC00011880
No longer blocks: 1045820
status-b2g-v2.1: --- → affected

Comment 3

3 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.