[traceback] AttributeError: 'NoneType' object has no attribute 'supported_locales'

RESOLVED DUPLICATE of bug 1149270

Status

P3
normal
RESOLVED DUPLICATE of bug 1149270
4 years ago
4 years ago

People

(Reporter: eviljeff, Unassigned)

Tracking

2014-Q4
Points:
---

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
The developer for 
https://marketplace.firefox.com/app/bangladesh-weather/
is trying to update his manifest url to: 
http://bnw.robinz.org/manifest.webapp

but we're getting a server error meaning it can't be updated.
"mkt.webapps.models in update_supported_locales
AttributeError: 'NoneType' object has no attribute 'supported_locales'"

http://sentry.mktmon.services.phx1.mozilla.com/mkt/marketplacefirefoxcom/group/11963/ 
  
Nothing obviously out of the ordinary about the new manifest or the existing app.
(Reporter)

Comment 1

4 years ago
Created attachment 8518987 [details]
updated manifest file

Comment 2

4 years ago
Created attachment 8519383 [details]
manifest.webapp

Updated manifest file. It should work now.
Tested on FxOS Simulator. Version 2.0

Comment 3

4 years ago
Created attachment 8519385 [details]
hosted.PNG

for the record, attaching a screenshot.
Simulator. FxOS version 2.0
(Reporter)

Comment 4

4 years ago
(In reply to mythrobins from comment #2)
> Created attachment 8519383 [details]
> manifest.webapp
> 
> Updated manifest file. It should work now.
> Tested on FxOS Simulator. Version 2.0

And the update works for you now on Marketplace?

Comment 5

4 years ago
(In reply to Andrew Williamson [:eviljeff] from comment #4)
> (In reply to mythrobins from comment #2)
> > Created attachment 8519383 [details]
> > manifest.webapp
> > 
> > Updated manifest file. It should work now.
> > Tested on FxOS Simulator. Version 2.0
> 
> And the update works for you now on Marketplace?

Nope. not in the marketplace.

Updated

4 years ago
Priority: -- → P3

Comment 6

4 years ago
forward duping because it has more data.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1149270
You need to log in before you can comment on or make changes to this bug.